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Revision History

The following table lists the current version of Intel Server Control (ISC) software.  The date indicates the release of
the most recent version of ISC causing the version number to change.

ISC Version Release Date

1.8 October 1998

Disclaimer

Intel Corporation (Intel) makes no warranty of any kind with regard to this material, including, but not limited to, the
implied warranties of merchantability and fitness for a particular purpose.

Intel assumes no responsibility for any errors that may appear in this document.

Intel makes no commitment to update nor to keep current the information contained in this document.

No part of this document may be copied or reproduced in any form or by any means without prior written consent of
Intel.

An Intel product, when used in accordance with its associated documentation, is "Year 2000 Capable" when, upon
installation, it accurately stores, displays, processes, provides, and/or receives date data from, into, and between the
twentieth and twenty-first centuries, including leap year calculations, provided that all other technology used in
combination with said product properly exchanges date data with it.

Nothing in this document constitutes a guarantee, warranty, or license, express or implied.

Intel disclaims all liability for all such guaranties, warranties, and licenses, including but not limited to: fitness for
particular purpose; merchantability; not infringement of intellectual property or other rights of any third party or of
Intel; indemnity; and all others.

The reader is advised that third parties may have intellectual property rights that may be relevant to this document
and the technologies discussed herein, and is advised to seek the advice of competent legal counsel, without
obligation to Intel.

The Intel Server Control product may contain design defects or errors known as errata that may cause the product to
deviate from published specifications.  Currently characterized errata are available on request.

I2C is a two-wire communications bus/protocol developed by Philips.

SMBus is a subset of the I2C bus/protocol and was developed by Intel.

Implementations of the I2C bus/protocol or the SMBus bus/protocol may require licenses from various entities,
including Philips Electronics N.V. and North American Philips Corporation.

† Third-party brands and names are owned by their respective companies.

Copyright  1998, Intel Corporation.
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1 Introduction to Intel ® Server Control

What Is Intel Server Control?
Intel® Server Control (ISC) is a server-management tool targeted for the departmental LAN
Environment, such as file, print, and/or application servers.  ISC uses the Desktop Management
Interface (DMI) 2.0 framework to manage Windows NT†, NetWare†, and UnixWare† server
hardware components.  ISC provides real-time monitoring and alerting for server hardware sensors.

ISC has two main software components:

• The managed server: ISC Server Instrumentation is installed on the NetWare, Windows NT, or
UnixWare server that is going to be managed by the ISC Console software.

• The managing console: ISC Console software is installed on the user console that will manage
the server.

On a Windows NT network, it is possible to install both parts of the software on the same server.
It is also possible to install both the Server Instrumentation and the Console software on multiple
systems.

Features
The following list summarizes the features of ISC:

• Graphical user interface
• Consolidated server health information
• Interchassis management via the Intelligent Chassis Management Bus (ICMB)
• Enterprise console support (ISC runs under HP Network Node Manager; LANDesk® Server

Manager; and CA-Unicenter† TNG)
• ISC stand-alone environment
• Remote installation
• Object-oriented framework using COM and ActiveX† technologies
• RPC-based transport mechanisms
• DMI 2.0 service providers
• DMI Explorer browser

System administrators can use ISC to:

• Remotely monitor server hardware sensors
• Configure sensor thresholds
• Update the server’s LCD display (if available)
• Configure, receive, and act upon alert events in the system event log (SEL)
• Configure audio or visual notifications in response to an event
• Configure options to shut down, reboot, or power-off the system automatically in response to

an event
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Tracking System Status
Using ISC, you are able to track system status and manage hardware conditions such as:

• Temperature
• Voltage
• Cooling fan status
• Chassis intrusion
• ECC memory
• Processor status
• Power supply status

Each of these conditions has a threshold or range of acceptable values.  Default values are
configured during system manufacturing.  These values, along with the current readings, error
status, and timer settings, can be configured and monitored through ISC.  An event occurs when a
parameter crosses a defined threshold.  At the time an event occurs, ISC initiates the action you
have configured.

For example, if the temperature reaches a level that is outside of the user-defined threshold, an
event has occurred.  You can configure ISC to respond to this event in multiple ways, such as:

• Display a message or sound an alert
• Shut down the server
• Record the event in a system log

You can also use ISC to view:

• System hardware inventory
• BIOS and system slot information
• Onboard Adaptec SCSI controller status
• Onboard Symbios SCSI controller status
• Onboard American Megatrends, Inc. (AMI) RAID controller status
• Onboard Intel® LAN adapter status
• Component instrumentation from previous versions of LANDesk Server Control (LSC)

running under LANDesk Server Manager (LDSM)

Managing Third-Party Components, DMI, and MIF
Files

ISC uses the Desktop Management Interface (DMI) to monitor components, such as hardware
sensors, inventory information, and third-party instrumentation on server systems.  ISC monitors
the motherboard, chassis, onboard Adaptec† and Symbios† SCSI controllers, onboard AMI RAID
controllers, and onboard Intel LAN adapters.  ISC also manages server instrumentation available
on previous versions of LANDesk Server Control (LSC) including Mylex RAID and APC UPS
instrumentation.
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To provide these capabilities, each DMI-enabled component must provide a Management
Information Format (MIF) file, which describes the manageable attributes of that component.  For
example, the current reading of a temperature sensor is an attribute that could be listed in a MIF
file.

The ISC Console GUI running on a local management console (Windows NT, Windows† 95, or
Windows 98) can manage components on a remote managed server (Windows NT, NetWare, or
UnixWare).  ISC also includes a translator to allow management of the DMI-enabled component
instrumentation from a remote SNMP application.

For more information on DMI, see the Desktop Management Task Force (http://www.dmtf.org) on
the World Wide Web.

Getting the Latest Information and Support
ISC is frequently enhanced and updated to support new features and platforms, and to address
issues discovered within the application.  For updated information on such changes, see the ISC
release note files (README.TXT and ERRATA.TXT).  If you have questions or need help using
ISC, contact your service representative.

Glossary
The following terms and abbreviations are used in this document:

Table 1. Glossary Information

Term Description

MIF Management Information File, used by DMI for describing component
instrumentation

MMC Microsoft Management Console

NMI Non-Maskable Interrupt

ONC Open Network Computing

RAID Redundant Array of Inexpensive Disks

RPC Remote Procedure Call

SBE Single-Bit Error

SCO Santa Cruz Operation, developer of SCO UnixWare

SEL System Event Log

SIMM Single In-line Memory Module
SMI System Management Interrupt

SNMP Simple Network Management Protocol, a standard network protocol for
management information

UPS Uninterruptable Power Supply
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2 System Requirements

ISC has two main software components:

• ISC Server Instrumentation software is installed on the NetWare, Windows NT, or UnixWare
server to be managed by the ISC Console software.

• ISC Console software is installed on a Windows NT server or workstation, or on a
Windows 95 or Windows 98 workstation, that will manage the server.

Both the managing console(s) and the managed server(s) must meet the minimum system
requirements listed below.

Managed Server Requirements
ISC supports several Intel motherboards.  For a complete list of supported server motherboards and
qualified BIOS revision levels, see the ISC release note files (README.TXT and
ERRATA.TXT).  The following requirements must be met for the NetWare, Windows NT, or
UnixWare managed server.

NetWare Requirements

If you intend to manage a NetWare server, you must have an account with supervisor- or
administrator-equivalent rights available to you.  The server must also meet the following
minimum requirements:

• NetWare 4.11 or 5.0 symmetric multiprocessing (SMP), or IntraNetWare† 1.0
• One of the Intel® motherboards specified in the release notes
• At least 24 MB of RAM
• At least 60 MB of available disk space
• NetWare SNMP NLM installed (required only for connectivity to an SNMP management

console)
• TIRPC (Transport Independent Remote Procedure Call) needs to be installed and configured

before an ISC console can communicate with NetWare servers.

For a NetWare 4.11 SMP, NetWare 5.0 SMP, or IntraNetWare 1.0 OS, the following NLMs, or
later versions, are necessary:

• CLIB.NLM, version 4.11
• FPSM.NLM, version 4.11
• THREADS.NLM, version 4.11
• REQUESTR.NLM, version 4.11
• NLMLIB.NLM, version 4.11
• NIT.NLM, version 4.11
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Windows NT Requirements
If you intend to manage a Windows NT server, you must have an account with administrative
rights available to you.  The server must also meet the following minimum requirements:

• Windows NT Server 3.51 (SP 5), 4.0 (SP 3), or Enterprise Edition
• One of the Intel motherboards as specified in the release notes
• 32 MB of RAM
• 60 MB of available disk space
• Windows NT SNMP or SNMP service installed (required only for connectivity to an SNMP

management console)

SCO† UnixWare Requirements

If you intend to manage a UnixWare file server, you must have an account with root privileges
available to you.  The server must also meet the following minimum requirements:

• SCO UnixWare 7
• One of the Intel motherboards supported under UNIX† as specified in the release notes
• 32 MB of RAM
• 60 MB of available disk space
• UNIX SNMP and ONC RPC installed

Additional Requirements for DMI-SNMP Translation

SNMP support must be installed if you want to integrate ISC with an SNMP-based management
framework.  For SNMP installation information, see your Windows NT, NetWare, or UnixWare
documentation.

On the managed server, you should consider the following issues when configuring SNMP:

• Community string names for SNMP Get and Set operations and for sending traps
• The destination address for the management console receiving the traps

On the management console, you should consider the following issues when configuring SNMP:

• Compiling the MIBs into the SNMP management consoles
• Integration of ISC traps into SNMP management consoles

Console Requirements
The ISC Console software integrates into HP Network Node Manager, Intel LANDesk Server
Manager, or CA Unicenter-TNG consoles.  See ISC release notes for supported versions of these
software packages.  ISC also runs in a stand-alone environment.  You can choose to install the
stand-alone environment during Setup.  If you do not choose the stand-alone environment and no
management console is present, the ISC GUI software will not install.
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Windows 95 or Windows 98
• Intel® Pentium® microprocessor or higher
• At least 32 MB of RAM
• At least 10 MB of available disk space

Windows NT
• Windows NT Server or Workstation 4.0
• Intel Pentium microprocessor or higher
• At least 64 MB of RAM
• At least 10 MB of available disk space
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3 Installing ISC

Managed Server Preparation
ISC uses the event-logging feature of the BIOS for system management status and information.  To
enable this feature for each server to be managed with ISC, you must boot the server(s) using the
System Configuration Utility (SCU) or System Setup Utility (SSU) and set the appropriate options
under System Management Options.  For motherboard-specific settings and values, see the ISC
release note files (README.TXT and ERRATA.TXT).

✏ NOTE
It is possible to configure temperature and voltage thresholds on the server
system using the SCU or SSU.  However, the thresholds set with the SCU or
SSU are in effect only for a short time during the system boot process.  ISC
overwrites these thresholds when the OS loads.  We therefore recommend
that all threshold changes be made using ISC.

Compatibility and Upgrade Issues
If you have earlier versions of LSC or LDSM on your network, be aware of the following:

• Versions of LDSM with LSC prior to 2.8 are not supported under ISC.
• The ISC-managed server installation will not upgrade the DMI service provider or any DMI

database that is already installed on the managed server.  However, if a service provider is not
found, ISC installs a DMI 2.0 service provider.

• The ISC server installation process installs the remote procedure call (RPC) transports (DCE
and ONC) if they are not available on the managed server.

• The enhanced ISC GUI uses RPC transports (DCE and ONC) and DMI 2.0 commands to
communicate with DMI 2.0-based managed servers.  However, an LSC 2.8-based ISC GUI is
used when managing a DMI 1.0-based server.  This 2.8-based GUI is included in the ISC
product and is automatically launched when a DMI 1.0-based server is detected.  This is
necessary because DMI 1.0-based servers do not support DMI 2.0 commands or RPC
transports.

Beginning with version 1.8, ISC ships with the DMI 2.0s Service Provider for Windows NT.  The
2.0s version is an extension of the Service Provider that supports security.   ISC does not use those
features, but they are available under Windows NT for possible use by other DMI 2.0s-compliant
software.
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The Setup Program
The Setup program installs the ISC software, the stand-alone ISC Console, and the ISC Server
Instrumentation software for Windows NT and NetWare servers.  To install the instrumentation
software for UnixWare servers, please refer to the section “Installing to a UnixWare Server.”

✏✏ NOTE
Before running Setup, verify that you have administrative rights for all
servers and consoles on which you will be installing ISC.

To start Setup:

1. Close all applications except the Windows Program Manager.
2. Run ISCSETUP.EXE.  If ISC was downloaded via the World Wide Web, run INSTALL.BAT

to rebuild and launch ISCSETUP.EXE.
3. Follow the Setup prompts.

The ISC Setup program configures both the Local Console and the Managed Server(s), through
four installation options:

• Local Console— Installs and sets up the ISC console components on the local system; detects
whether any supported enterprise management consoles are installed; and configures the ISC
console components to launch from these management console applications.  This option may
be selected only on a Windows NT server or workstation, or on a Windows 95 or a Windows
98  workstation.

• Stand-alone environment— Installs and sets up the stand-alone ISC environment on the local
server; and configures the ISC console components to launch from this application.  This
option may be selected only on a Windows NT server or workstation, or on a Windows 95 or a
Windows 98 workstation.

• Local Server Instrumentation— Installs and sets up the ISC server components on the local
server.  This option may be chosen only on a Windows NT server.

• Remote Server Instrumentation— Installs and sets up the ISC server components on the
selected remote servers.  ISC supports a remote concurrent installation process (from a
Windows NT system) by allowing you to configure drive mappings to multiple remote servers
during Setup.  This allows you to install ISC onto multiple remote servers at the same time.
This option may be selected for either a Windows NT or a NetWare server.
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Local Console Overview
Setup does the following:

• Creates necessary directories.
• Copies installation files to the Local Console.
• Registers the ActiveX controls.
• Configures the system, including registry changes.
• Configures ISC to run under HP NNM, Intel LANDesk Server Manager (LDSM) , or CA

Unicenter-TNG, if these management consoles are installed.
• Configures ISC to run in a stand-alone environment if the stand-alone environment is installed.

The ISC Console software runs under Windows NT 4.0, Windows 95, and Windows 98.  The
appropriate GUI will run automatically depending on the DMI services detected on the managed
server.

• The enhanced ISC GUI is used when DMI 2.0 services are installed.
• The 2.8-based LSC GUI is used when DMI 1.0 services are installed.

When the ISC Console is installed on a Windows NT 4.0 server, the server can act both as a Local
Console and as a Managed Server if the server contains an ISC-supported motherboard and you
install the instrumentation software and the Local Console software.

The ISC Console software is launched from enterprise management consoles that are detected
during Setup and configured to run ISC.  ISC supports these consoles during Setup (see the ISC
release notes for supported versions of these software packages):

• HP Network Node Manager: Windows NT only
• LANDesk Server Manager: Windows NT and Windows 95
• CA Unicenter-TNG: Windows NT only

✏✏ NOTE
ISC also installs the DMI Explorer browser under HP-NNM, CA Unicenter-
TNG, and the ISC Stand-alone environment.

Setup will automatically configure each detected enterprise management console to launch ISC.  If
more enterprise management consoles are installed later, you must rerun the ISC Setup program to
configure the ISC Console software to run under the additional management console.  If Setup
does not detect any of the enterprise management consoles on the local machine or you have not
chosen to install the ISC stand-alone environment, the ISC console components will not be
installed.

Stand-alone ISC Console Overview
Setup does the following:

• Creates necessary directories
• Copies installation files to the Local Console
• Registers the ActiveX controls
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• Configures the system, including registry changes
• Configures ISC to run in the stand-alone environment

Use the ISC stand-alone environment to manage your servers without having an enterprise
management console installed on your local server.  The stand-alone ISC Console runs under
Windows NT 4.0, Windows 95, or Windows 98, either as an executable program, an ActiveX
control inside of a 32-bit Internet browser, or inside of the Microsoft Management Console
(MMC).  Using the stand-alone environment, you can discover ISC-managed servers and run the
ISC Console software for those managed servers.

Managed Server Configuration
Setup does the following:

• Creates necessary directories
• Verifies software dependencies and configuration
• Installs DMI 2.0 service provider if no DMI environment is detected
• Detects the motherboard and chassis type
• Copies installation files to the server
• Edits system startup files
• Sets up and configures the system, including registry changes
• Reboots the server

On NetWare servers, you must manually reboot the server to complete the ISC installation.

Local Server Instrumentation

Select this option so that Setup will install the ISC Instrumentation software directly on the server
from which Setup is initiated.  The option is valid for a local server running Windows NT 4.0.
With this option, Setup:

• WILL upgrade the motherboard instrumentation if a previous version is found.  The old
instrumentation is saved in a BACKUP directory.

• WILL install the DCE RPC transport if it is not available on the local server.
• WILL NOT install any ISC server instrumentation if Setup determines that the local machine

does not have a supported motherboard.

It is possible to configure both the Local Server Instrumentation and the ISC Console software on
the same Windows NT server.  Windows NT 4.0 servers can act both as managed servers and as
ISC Consoles.

Setup checks for DMI services on the local server.  Setup will not upgrade a DMI service provider
or a DMI database that is already installed on the local server.  If a DMI service provider is not
found, ISC installs a Win32† -based DMI 2.0 service provider on the local server.
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✏✏ NOTE
Servers that have a DMI 1.0-based service provider can be managed by ISC
through a 2.8-based LSC GUI that is installed during the ISC console
installation.

Remote Server Instrumentation

Select this option to install the ISC Instrumentation software at one or more remote Windows NT
servers, one or more NetWare servers, or a combination of Windows NT and NetWare servers.
Remote install is supported from a system running Windows NT.  For UnixWare servers, refer to
the corresponding section for installation instructions.  With this option, Setup:

• WILL upgrade the motherboard instrumentation.  If a previous version is found, the old
instrumentation is saved in a BACKUP directory.

• WILL install the RPC transports (DCE or ONC) if they are not available on the remote server.
• WILL NOT install the ISC server instrumentation if Setup determines that the remote machine

does not have a supported motherboard.

You can configure remote drive mappings to servers on which you want to install the ISC server
instrumentation.  Requirements:

• You must have administrator or equivalent rights for each server on which you will be
installing the software.

• You may have to create a network share on the remote server depending on which drive or
directory you want to install ISC onto.

• You can use your own named network share, or use the default share for the drive.

After you manually configure the remote drive mappings to your installation directory, Setup will
simultaneously install the ISC server instrumentation to each server.  Setup creates a long-term
connection to the remote machine when you configure the remote drive mappings.  The mapping
continues once the ISC installation is complete.  You must manually delete unwanted drive
mappings.

Setup checks for DMI services on the remote server.  Setup will not upgrade a DMI 2.0-based
service provider or DMI database if one is already installed on the remote server.  If no DMI
service provider is found, ISC will install a Win32 or NetWare-based DMI 2.0 service provider on
the remote server.

✏✏ NOTE
Servers that have a DMI 1.0-based service provider can be managed by ISC
through a 2.8-based LSC GUI that is installed during the ISC console
installation.

Installing on a Windows NT Server
The Setup program automatically creates directories, copies files, updates registry entries, and
configures services.  Setup will reboot the server to complete installation.



20

Installing on a NetWare Server
Setup updates NetWare servers in two parts:

1. Files are copied to the NetWare server from the computer from which Setup is initiated.
2. After Setup has finished copying files to the NetWare server, you must reboot the NetWare

server to complete the ISC installation.  Following the reboot, a configuration and setup
program runs at the NetWare server.  The ISC configuration and setup program detects the
motherboard type and installs the ISC software.

If an ISC-supported motherboard is not detected during the ISC configuration and setup process,
all ISC-related files are deleted from the NetWare server.  A warning message is displayed on the
NetWare console indicating that ISC did not install correctly.

The ISC configuration and Setup program adds a call, ISC_ON.NCF, to NetWare’s
AUTOEXEC.NCF.  This allows the ISC server instrumentation NLMs to automatically load with
the NetWare OS.  To start the ISC server instrumentation, you can manually start ISC_ON.NCF, or
reboot the server to start the ISC server instrumentation automatically with the NetWare OS.

NetWare Server Customization After Running Setup

While installing ISC, the configuration and Setup program installs Adaptec and Symbios SCSI,
AMI RAID, and Intel LAN Adapter instrumentation on the NetWare server but does not enable
the instrumentation support.

To enable support for any or all instrumentation, you must edit the ISC_ON.NCF file in the
SYS:SYSTEM directory.

To enable the Adaptec SCSI instrumentation, remove the word REM from these lines in the
ISC_ON.NCF file:

REM load iomgr

REM load cio20

REM load ciodmi

To enable the Intel LAN Adapter instrumentation, remove the word REM from these lines in the
ISC_ON.NCF file:

REM load intelndm

REM load intel_ni

To enable the AMI RAID instrumentation, remove the word REM from these lines in the
ISC_ON.NCF file:

REM load megaci

REM load amiagent

To enable the Symbios SCSI instrumentation, remove the word REM from these lines in the
ISC_ON.NCF file:

REM load symcinw
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To enable the Mylex RAID instrumentation, remove the word REM from these lines in the
ISC_ON.NCF file:

REM LOAD GAMDRV

REM LOAD GAMSTUBS

REM LOAD GAMSERV

REM LOAD GAMEVENT -h <IP Address>

REM LOAD RAIDBLD -s 7 -S 1 -r -R 1 -t 24 -T 0 -l sys:\public\raidbld.log

REM LOAD GAMCONFG -c 1 -t 16 -T 1111111101111111

REM LOAD GAMSETSZ -f sys:\system\mylexdrv.siz

REM LOAD MDACCI

Installing on a UnixWare Server
Installation for UnixWare servers must be done on individual servers locally, not by using ISC
Setup.

You must be logged on as root.

The UNIX package will be installed by default in /isc directory.  If you want to install it in a
different directory, edit the file /var/sadm/install/admin/default, and change the value of basedir
parameter to “ask” rather than “default.” In this case, pkgadd will prompt for the base directory—it
will create the directory isc inside that.

Mount the CD-ROM in read-only mode.  To mount the CD-ROM, run “mount –rF cdfs
/dev/cdrom/* /install” or, if more than one CD-ROM driver is present in the system, note the name
of the driver from directory /dev/cdrom, and replace * with the driver name in the mount
command.

To install the UNIX package:

1. Run “pkgadd –d /install/ISC/UNIXWARE/ISCUW.PKG”.  Commands are case-sensitive.
2. If the system motherboard is S450NX and if the board supports ICMB, set execute permission

to the files isc/eif and isc/asyncpoller.
3. Change directory to "isc." The default path is /isc.  Use the command "chmod +x eif

asyncpoller."

Once the installation is complete, reboot the system.  All the ISC daemons will be up and running
minutes after the system is up.  The daemons are dmispd, oncsp, basebrd, lra, sdlink, and sdtrap.
On ICMB enabled servers, the eif and asyncpoller are optional modules as explained above.
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Installing the Console on a Workstation
The Setup program installs the Local Console and the stand-alone ISC Console on a workstation.
The program automatically creates the directories, copies files, updates registry entries, and
configures services.  Setup will reboot the server to complete installation.

You must have Administrator or equivalent rights on the workstation in order for the ISC Console
programs to install properly.

Uninstalling ISC
The uninstall process differs between Windows NT, NetWare, and UnixWare.

Windows 95, Windows 98, and Windows NT 4.0

To delete the ISC components, run the Add/Remove Program function from the Control Panel on
the local server, and select the following programs:

• Intel Server Control Console—deletes the ISC console, including the enhanced GUI and
2.8-based applet, DMI browser, and enterprise management console files.

• Intel Server Control Instrumentation—deletes the ISC server platform instrumentation.
• Intel DMI 2.x Service Provider—deletes the DMI 2.0 service provider, DMI database, and

RPC transport files.  Do NOT delete this component if other DMI applications are installed
on the server.

We recommend that you reboot the server after uninstall.

Windows NT 3.51

To delete the ISC server instrumentation component, log on to the local server and run the
CIUninstall.bat  script from the %ISCPATH% directory.  We recommend that you reboot the
server after uninstall.

NetWare

To delete the ISC server instrumentation component, log on to the local server as a user with
administrative rights, and run the following two scripts from the SYS: SYSTEM directory:

• ISC_RM.NCF—deletes the ISC server platform instrumentation.
• DMI_RM.NCF —deletes the DMI 2.0 service provider, DMI database, and RPC transport

files.  Do NOT run this if other DMI applications are installed on the server.

We recommend that you reboot the server after uninstall.

SCO UnixWare

To delete the server instrumentation, login as root.  Run “pkgrm” and follow the instructions.
Afterwards, reboot the machine.
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4 Launching ISC

ISC can be launched from and can manage your server from one of these enterprise management
environments:

• LANDesk Server Manager (LDSM)
• HP Network Node Manager
• CA-Unicenter TNG

Once the ISC GUI application is launched from an enterprise management console, the
management console application can terminate, and ISC will continue to operate normally.

ISC can be launched from and can manage your server from a stand-alone ISC Console.  The ISC
Console can run as an executable program, as an ActiveX control within an Internet browser, or
within Microsoft Management Console.

LANDesk ® Server Manager
The LDSM console dynamically builds its feature set when communication is established with a
managed server.  If the managed server is running the ISC Component Instrumentation software,
the LDSM console adds an option for “Intel Server Control” as a launch point in the Tools branch
of the LDSM navigation tree.  Select this option to launch the ISC applet.

HP Network Node Manager
The HP Network Node Manager Console autodetects servers running the ISC Component
Instrumentation software.  The Console updates the server bitmap with an ISC server icon for those
servers.

To launch the ISC applet, select an ISC-enabled server on the HP Console network map, and then
select the "Intel Server Control Applet" option from the Tools Menu.  Alternatively, you can
launch the ISC applet by selecting an ISC-enabled server on the HP console network map, clicking
the right mouse button, and then selecting the "Intel Server Control" option from the popup menu.

CA-Unicenter TNG
The CA-Unicenter TNG Console autodetects servers running the ISC Component Instrumentation
software if you have enabled the ISC to CA discovery service.  To enable discovery, you must start
the "Intel Tng-ISC AutoDiscovery" service.  You can start this service from either the TNG
Unicenter "Auto Discovery" dialog or from the Windows NT "Services" applet.

The "Intel Tng-ISC AutoDiscovery" service creates a new "Intel Server Control" TNG object for
each server having the ISC Component Instrumentation software.  That TNG object displays on the
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map as a child of the "ISC World View" and as a child of the ISC-enabled server.  You can view
all ISC-enabled servers under the "ISC World View."

To launch the ISC applet, right-click on a "Intel Server Control" icon, and select the “Launch ISC"
option from the popup menu.

Stand-alone ISC Console
Use the stand-alone ISC Console to manage ISC-enabled servers without installing an enterprise
management console application.  The environment is implemented as an executable program; as
an application within Microsoft Management Console; or as an ActiveX control that runs within a
“container” application, such as Microsoft Internet Explorer, versions 3.0 or 4.0, or Netscape
Navigator, version 3.0 or 4.0.

Refer to Appendix A for details about the features supported by the stand-alone ISC Console.

Launching the ISC Console

To launch the stand-alone ISC Console in its own container, do the following:

1. From the Start Menu in Windows, select Start->Programs->Intel Server Control Tools->Intel
Server Control.

Launching the ISC Console with Internet Browsers

To launch the stand-alone ISC Console within a Web browser, do the following:

1. Run the Internet Browser to be used as a “container” for the ISC Console.
2. Within the browser, choose File->Open.
3. Enter the ISC Console filename, specifying the full path to the file:

%ISCPATH%\MI\EMC\IC\ISC.HTM

The stand-alone ISC Console will be started as the active application within the default Web
browser.

Once the ISC Console is loaded, the location can be saved as a “Bookmark” (Netscape) or a
“Favorite” (Internet Explorer) for easy access in later sessions.

You may also:

1. Locate the file using Windows Explorer, specifying the path:
%ISCPATH%\MI\EMC\IC\ISC.HTM

2. Double-click on the filename to launch the control within the default Web browser.

NOTE
Netscape Navigator requires a plug-in for viewing ActiveX applications.
One that is known to work is ScriptActive†, which available from Ncompass
Labs, Inc. (see http://www.ncompasslabs.com).
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Launching the ISC Console with Microsoft Management Console

To launch the stand-alone ISC Console within Microsoft Management Console (MMC), do the
following:

1. From a Start Menu in Windows or from the StartÆRun selection, run MMC.
2. Within MMC, choose FileÆOpen.
3. Enter the ISC Console filename, specifying the full path to the file:

%ISCPATH%\MI\EMC\IC\ISC.MSC

The ISC stand-alone application will be started as the active application within MMC.  You may
also:

1. Locate the file using Windows Explorer, specifying the path:
%ISCPATH%\MI\EMC\IC\ISC.MSC

4. Double-click on the filename to launch the control within MMC.

✏✏ NOTE
If you have not installed MMC on your console system, you can obtain it
from Microsoft at http://www.microsoft.com/management/mmc/.

http://www.microsoft.com/management/mmc
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5 Navigating ISC

When you start the ISC, the main window displays a tree view.  You can expand the view to show
the sensor types supported on the managed server and further expand it to display detailed sensor
information.

A presentation area on the main ISC window displays current readings, threshold configurations,
inventory, and other related information for selections made in the tree view.  The main window
also displays the server’s LCD (if available) and a picture of the ISC bitmap.

Most of the ISC sensors have associated thresholds that trigger alert actions when the thresholds
are crossed.  You can:

• Specify which alert actions you want to occur.
• Modify the default thresholds.
• Configure the default actions and notifications for each threshold.

When a parameter crosses a threshold, you can have ISC:

• Beep the speaker on the managed server.
• Display an alert on the managed server.
• Log the event to disk on the managed server.
• Broadcast a message.
• Write a message to the LCD on the managed server.
• Use one of the shutdown/power control options to shutdown the OS, do a hardware reset, or

power-off the server.
• Run any LANDesk Alert Management System (AMS2

 ) alert action if LANDesk Server
Manager is installed on the managed server and managing console.  For more information on
AMS2, see the Intel LANDesk Server Manager Administrator’s Guide.
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The ISC Console Main Screen
ISC uses a Windows Explorer-like model, with a navigation pane (tree view) and a presentation
pane (list view).  When you select a sensor from the tree, the presentation pane shows a set of
tabbed pages with sensor-specific information.

A             B          C

G           F        E                                 D

Figure 1.  ISC Main S creen

A Main Menu bar (for more details, see page 23)
B Icon Toolbar (page 24)
C Navigation Pane (page 30)
D Presentation Pane (page 31)
E ISC Bitmap (page 30)
F LCD Display Pane (page 30)
G Status Bar (page 30)

The main screen of the ISC application is continually updated to show current sensor status.
Specific ISC sensor dialogs (such as temperature and voltage sensors) show the current sensor
reading when displayed but are not dynamically updated.
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Main Menu Bar
The Main Menu Bar includes the following options:

Table 2. Main Menu Bar Items

Item Options

File Menu Exit:  Exits the application

View Menu Toolbar:  Toggles the toolbar on or off
Status Bar:  Toggles the status bar on or off
ISC Bitmap:  Toggles the ISC bitmap pane on and off
Large Icons:  Displays list using large icons
Small Icons:  Displays list using small icons
List:  Displays items in list format
Details:  Displays items in detail format
Arrange Icons:  Arranges icons by name or status
Refresh:  Triggers an immediate screen and data refresh
Options:  Displays the view options dialog so you can configure viewing preferences
such as temperature format and display refresh rate

Configure Menu Enable Front Panel Power & Reset:  Toggles the front panel power and reset option
Immediate Power Off (On) Server:  Immediately powers off the managed server or
ICMB-managed device.  If the device is powered off, this option powers it on.  Power
On is available only on ICMB devices
Immediate Hardware Reset Server:  Immediately resets the managed server or
ICMB-managed device
Enable Watchdog Timer:  Toggles the watchdog timer option.  When this option is
enabled, you can set the timer value
Watchdog Timer Value:  When the watchdog timer option is enabled, the timeout
dialog appears so you can set the timeout value.  When the timer is disabled, the
dialog does not appear
Restore Factory Defaults:  Restores factory default values for threshold sensors,
console refresh interval, and the Watchdog Timer

ICMB Menu View Managing Server:  Enables the default local managing server view

View  Managed Server(s):  Accesses the ICMB-managed server view(s)
Reclaim Inactive Resources:  Reclaims inactive ICMB resources on the managing
server

Help Menu Help Topics:  Accesses ISC help topics
About ISC:  Displays ISC version information
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Icon Toolbar
Table 3 lists the items in the Icon Toolbar.  The order of the items in the table, top to bottom,
reflects the order of the icons on the main screen, left to right.  To hide the icon toolbar, click the
right mouse button over the toolbar, and then click on the “Hide” popup menu that appears.

Table 3. Icon Toolbar Items

Icon Name Options

Up One Level Takes you up one level in the tree (navigation) view

ISC Bitmap Toggles the ISC bitmap pane on or off

Large Icons Displays list using large icons

Small Icons Displays list using small icons

List Displays items in list format

Details Displays items in detail format

Navigation Pane
The Navigation Pane shows a tree view of server components that can be monitored.  Many
branches of the tree represent group components that have subbranches (nodes).  These group items
are identified by the tree expansion icons (“+” or “-”) appearing to the left of the component name.
These branches can be expanded to list nodes (detail sensor list) or collapsed to hide nodes.

ISC Bitmap
The ISC Bitmap shows a picture of the ISC splash screen.  To hide the picture, click the right
mouse button over the picture, and then click on the “Hide” popup menu that appears or click on
the ISC Bitmap icon on the toolbar.

LCD Display
The LCD Display Pane shows the actual server LCD contents and a button to set the LCD contents
on the server.  If the server hardware does not support LCD, the pane does not display.

Status Bar
The Status Bar displays status messages.  To hide the status bar, click the right mouse button over
the status bar, and then click on the “Hide” popup menu that appears.
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Presentation Pane
When you select a branch (group component) in the navigation pane, the presentation pane displays
a set of icons (list view) representing each group node (detail sensor list).  The detail view provides
more information on each node item.  You can arrange these list view items by name (sorted
alphabetically) or by status (sorted by current status: critical, noncritical, and OK).  To change the
presentation pane, click the right mouse button over the pane, and then select from the popup menu
that appears.  This popup menu has two items:

• View— Changes between large icons, small icons, list, or detail view
• Arrange Icons— Arranges the list view icons by name or status

When you select a node in the navigation pane, the presentation pane displays a set of tab pages
representing the detail sensor information.  Depending on the node selected in the navigation pane,
one of the following four pages is displayed:

• Sensor Settings— Displays the sensor’s current status and current value, threshold values and
error counts.

Use this screen to configure new threshold values (such as Upper Critical Threshold, Upper
Noncritical Threshold).

The sensor status is also represented as a colored “Health” icon: Red is critical, Yellow is
noncritical, and Green is OK.

• Alert Actions— Displays the currently configured alert actions for each threshold type (such
as Voltage-Status Changed to Upper Critical, Voltage-Status Changed to Lower Critical).

Use this screen to change the alert actions for each supported threshold.  The factory default
alert actions are Log the Event to Disk and Write a Message to the LCD.  The AMS Alert
configuration option is available only when ISC is integrated with LDSM; when this feature is
not available, the AMS Alert option is disabled.

• Sensor Information— Displays individual sensor information (such as Sensor Tolerance,
Maximum Reading, Minimum Reading).

• Inventory Information — Displays inventory information for the sensor (such as Description,
Manufacturer).  The information varies based on the sensor type.

Health of the Server
You can select the Health branch of the server tree in the navigation pane to get a quick and simple
view of the current server health.  Information about all unhealthy sensors is copied under the
Health branch.  If, for example, a 12V voltage sensor indicates that the current status is not OK,
then data about that 12V sensor is added to the Health branch of the tree.  You can select the 12V
entry in either the Health or Voltage branch of the tree to display information about the sensor.

All sensors in either a critical or noncritical condition will appear in the Health branch of the tree in
addition to their normal location in other areas of the navigation tree.  In this way, you can get a
quick summary of problem areas on your server and begin corrective actions.
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Colored icons in the Health branch of the server tree indicate individual sensor status and overall
server status:

• Green: healthy server
• Yellow: noncritical conditions
• Red: critical failures

The color of the overall server health icon will display the state of the most severe sensor status.  If
any sensor is in a critical condition (regardless of other sensors being in a noncritical condition),
the server health status will be shown as critical (red).  If there are only noncritical sensors, the
server health status will be shown as noncritical (yellow).  If all sensors report normal conditions,
the server health status will be shown as OK (green).
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6 Managed Components

The following sensors and components can be managed by ISC:

• Voltage Sensors
• Temperature Sensors
• Watchdog Timer
• System Fans
• Chassis Sensors
• Processor Sensors
• System Power Supply Sensors
• System Power Redundancy
• ECC Memory
• System Information
• System Event Log
• LCD
• Front Panel Power and Reset Buttons
• Power State
• ICMB
• Third-party Instrumentation

Each of these is discussed in the following sections.

Voltage Sensors
In a managed server, ISC monitors many types of voltage sensors; the number and type depend on
the server hardware configuration.  Each monitored voltage sensor has independently configurable
thresholds and event actions.  Example voltage sensors are:

• 12V, 5V, 3.5V, 3.3V, -5V, -12V
• Processors 1.5V and 2.5V
• SCSI A Termination 1, 2, and 3

If a voltage threshold is crossed, the ISC Console software displays the noncritical or critical
condition via the “health branch” of the software, and the requested event actions are carried out.
If a particular voltage threshold is not available on your server, this threshold setting will be grayed
out, or inaccessible, in the ISC Console display.
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Table 4 displays the information available for the voltage sensors.

Table 4. Voltage Sensor Information

Item Description

Maximum Reading The highest reading supported on this sensor.

Minimum Reading The lowest reading supported on this sensor.

Sensor Accuracy The sensor’s accuracy in +/- hundredths of a percent.

Sensor Tolerance (plus) The amount of variation over the actual value that can be reported.

Sensor Tolerance (minus) The amount of variation under the actual value that can be reported.

Sensor Resolution The smallest unit of measurement reported by the sensor.

Nominal Reading The expected normal reading for this sensor.

Lowest Normal Reading The lowest normal reading of this sensor.  Readings below this value indicate
an abnormal condition.

Highest Normal Reading The highest normal reading of this sensor.  Readings above this value
indicate an abnormal condition.

Temperature Sensors
The number and type of temperature sensors monitored depends on the managed server hardware
configuration.  Each sensor has independently configurable thresholds and event actions.
Examples of temperature sensors include:

• I/O slot area
• Motherboard
• Processors 1 and 2

If a temperature threshold is crossed, the ISC Console software displays the noncritical or critical
condition via the health branch of the software, and the requested event actions are carried out.  If a
particular temperature threshold is not available on your server, this threshold setting will be
grayed out, or inaccessible, in the ISC Console display.

Table 5 displays the information available for the temperature sensors.

Table 5. Temperature Sensor Information

Item Description

Maximum Reading The highest reading supported on this sensor.

Minimum Reading The lowest reading supported on this sensor.

Sensor Accuracy The sensor’s accuracy in +/- hundredths of a percent.

Sensor Tolerance (plus) The amount of variation over the actual value that can be reported.

Sensor Tolerance (minus) The amount of variation under the actual value that can be reported.

Sensor Resolution The smallest unit of measurement reported by the sensor.

Nominal Reading The expected normal reading for this sensor.

Lowest Normal Reading The lowest normal reading of this sensor.  Readings below this value indicate
an abnormal condition.

Highest Normal Reading The highest normal reading of this sensor.  Readings above this value
indicate an abnormal condition.
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Watchdog Timer
Each motherboard supported by ISC has a watchdog timer implemented in the hardware; the timer
is disabled by default.  You can enable this timer.  When enabled, the timer continually decrements
to test the response of the server operating system.  Under normal operating conditions, the timer
will be periodically reset by the ISC server instrumentation software to prevent it from reaching a
value of zero.  If the OS hangs, the timer will count down to zero.

If the timer reaches a value of zero, indicating an OS hang, the watchdog timer will reset the
system.  The default timer value is two minutes with minimum and maximum allowable settings of
two to sixty minutes.

System Fans
ISC monitors two types of fans:

• Rotation-sensing fans—ISC can detect whether a fan has stopped but is not able to indicate
which fan has failed.  These fans, together, are treated as a single fan unit.  Therefore, event
actions must be configured for all fans together, rather than separately.

• RPM-sensing fans—ISC can detect whether an individual fan has either slowed or stopped and
will display the actual fan RPM value for systems that support this feature.  Each RPM-sensing
fan is independently configurable with its own threshold and event actions.

If a rotation-sensing fan fails or an RPM-sensing fan crosses a threshold, the ISC Console software
displays the event as a critical condition via the health branch of the software, and the requested
event actions are carried out.

For systems that do not support a fan RPM threshold, the threshold setting displays a “0” and is
read-only in the ISC Console display.

Chassis Sensors
ISC monitors chassis door open/closed switches for managed servers that support this feature.  The
number of sensors monitored depends on the server chassis.

When a chassis door that includes an open/close switch is opened, the vulnerable state is indicated
as a critical condition in the health branch of the ISC Console software, and the requested event
actions are carried out.  When all chassis doors that include an open/close switch are closed, ISC
indicates the chassis is secure and carries out the requested event actions.

For systems that do not support chassis open/closed switches, this portion of the ISC Console
software will either not display or the chassis status will be reported as “Unknown.”

Processor Sensors
For motherboards that support it, ISC monitors processor failures during runtime and system boot
on the managed server.  If a supported motherboard includes multiple processors, each processor
can be configured and monitored separately through ISC.  If a processor failure is detected, the
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failure is reported as a critical condition in the health branch of the ISC Console software, and the
requested event actions are carried out.

If processor sensors are not available on the motherboard, this portion of the ISC Console software
does not display.

System Power Supply Sensors
For systems that support it, ISC monitors the status of the power supplies in the managed server.
Each power supply is independently configurable for event actions upon failure.

If a power supply reports a predictive failure condition, then ISC reports the status as a non-critical
condition in the health branch of the ISC Console software, and the requested event actions are
carried out.

If a power supply fails, the failure is reported as a critical condition in the health branch of the ISC
Console software, and the requested event actions are carried out.  ISC also reports the system
power as nonredundant and as a noncritical condition in the health branch of the ISC Console
software, and the requested event actions are carried out.

For systems that do not support power supply sensors, this portion of the ISC Console software
will not display.

System Power Redundancy
For those systems that support it, ISC monitors the managed server’s system power redundancy
status.

If a power supply fails or if the surplus power on the system is less than the amount provided by
one power supply, ISC reports that the system power is Non-redundant.  This condition is indicated
with a noncritical status in the health branch of the ISC Console software and the requested event
actions are carried out.

For systems that do not support system power redundancy status, this portion of the ISC Console
software does not display.

ECC Memory
ISC reports memory status information, both memory arrays and memory devices, for systems that
support ECC memory.  The ECC memory subsystems can detect and report both single-bit errors
(SBE) and multiple-bit errors (MBE).

Depending on the managed server hardware, memory devices are either SIMMs or DIMMs.
Memory device references use the appropriate device name in the ISC Console software.
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Single-Bit Error Handling

If an SBE occurs, the system generates an SMI that allows the BIOS to log information about the
error in the System Event Log (SEL).  This information identifies the exact SIMM or DIMM in
which the error occurred.  Because this condition is recoverable, the BIOS returns the system to
normal operation after logging the error.

This error is indicated in the health branch of the ISC Console software as a noncritical condition,
the requested event actions are carried out, and a noncritical error count is incremented on the
Sensor Settings tab page of the software.

Also, the following actions occur in the ISC Console software:

• The Device Error Type is set to SBE on the Sensor Information tab page for the Memory
Device

• The Last Error Update value is set to “During ISC Runtime,” indicating the update occurred
while the system was operational.

The BIOS stops logging noncritical SBEs when the SBE error count reaches nine.  This prevents
the errors from filling the SEL.  Upon system reboot, the OS uses the SEL records, along with the
results from its own memory test, to map out bad memory by reducing the usable size of a memory
bank to avoid using the bad memory element(s).  This elimination of hard errors is a precaution
that prevents SBEs from becoming MBEs after the system has booted, and also to prevent SBEs
from being detected and logged each time the failed location(s) are accessed.  Upon reboot, the
SBE error count is set to zero in the SEL.

Multiple-Bit Error Handling
If an MBE occurs, the system generates an SMI that allows the BIOS to log information about the
error in the SEL, identifying the memory bank in which the error occurred.  However, on some
systems, it is not possible to determine the exact SIMM/DIMM that caused an MBE.

Because an MBE is a critical condition, upon logging the error the BIOS generates an NMI that
halts the system.  Upon rebooting the server, this error is indicated as a critical condition on the
Memory Array and Memory Device in the health branch of the ISC Console software.  The
requested event actions are carried out, and the critical error count is incremented on the Sensor
Settings tab page of the software.

Also, the following actions occur in the ISC Console software:

• The Device Error Type is set to MBE on the Sensor Information tab page for the Memory
Device.

• The Last Error Update value is set to Previous Boot, indicating the last update occurred during
the last system boot.
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Memory Tables

Tables 6, 7, and 8 compare the steps taken with Single-bit and Multi-bit errors and provide the type
of memory information available from the ISC Console software.

Table 6. SBE and MBE Comparison

Memory Error Handling SBE MBE

Generate SMI Yes Yes

Log information includes Exact SIMM or DIMM Memory bank only

Action after SEL logging Continue operation Stop the system

Indicated by ISC screen changes Immediately After the system reboots

Bad memory is mapped out at next reboot Yes Yes (immediately after the failure)

Information available on the Sensor Information tab page of the ISC Console software:

Table 7. Memory Array Dialog

Item Description

Maximum Memory Capacity The maximum memory capacity in bytes on this system

No. of Memory Device Sockets The number of memory device (SIMM/DIMM) slots or sockets
available in this memory array

No. of Memory Device Sockets Used The number of slots or sockets populated by the memory
devices in this memory array

Memory Error Correction The hardware error correction or detection method
supported by this memory array

Memory Array Location The physical location of the memory array, whether on the
motherboard or an add-on board

Information on the Sensor Information tab page of the ISC Console software:

Table 8. Memory Device Information

Item Description

Size Size of the memory device in bytes.

Memory Type Type of memory used in the memory device.

Device Locator A string identifying the socket location or board position of the memory device.
Example: “SIMM 3” or “IC12.”

Device Error Type Most recent type of error that occurred on the memory device.

Last Error Update System state during the last error update.

Total Width Total width of the memory device (SIMM/DIMM including check bits), in bits.

Data Width Data width of the memory device in bits.

Type Detail More information about the memory device type.

Error Count Summary of the error status for the memory device.  This read-only attribute
contains a count of all SBEs on the memory device.
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System Information
ISC gathers information on field replaceable unit (FRU) components installed in your managed
server.  This information includes a component description, manufacturer, model, part number,
component number, serial number, and revision level.  ISC also gathers information on other
system resources including Operating System, BIOS, System Slots, and the System Event Log.

If your server does not support one or more of these features, these portions of the ISC Console
software will not display.

System Event Log
The ISC Console software displays the System Event Log (SEL) maintained by the managed
server’s platform hardware.  The SEL is a collection of log entries stored in nonvolatile flash
memory.  The entries are reported by the BIOS SMI handler when an event condition occurs at the
server.

The ISC Server Instrumentation automatically extracts event information from the SEL and
triggers any user-configured actions associated with that event.  The ISC Server Instrumentation
clears the SEL when it is near an out-of-space condition.  The ISC Console software also displays
the SEL logging status (whether the SEL is Active or Inactive).

The SEL information is reported only on managed server hardware platforms that support a SEL.

LCD
ISC displays the contents of the system LCD and allows changes to the LCD’s contents.  If your
chassis does not support this feature, ISC does not report this information.

Front Panel Power and Reset Buttons
Through the ISC, you can enable or disable the power and reset buttons on the front panel of the
managed server chassis.  The buttons are enabled by default.  This feature is disabled for servers
that do not support it.

Power State
Through the ISC, you can do an immediate power-off or hardware reset of the currently managed
server or ICMB-managed device.  You can also do an immediate power-on if the ICMB-managed
device is in a powered-down state.
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ICMB
The Intelligent Chassis Management Bus (ICMB) feature allows multiple remote devices to be
interconnected and management information shared among them.  For example, your managed
server could be configured to be an ICMB primary server and report management information on
other ICMB devices connected to it.  Using ICMB, ISC can manage the power state of remote
ICMB devices and view FRU information about those devices.  The amount of FRU information
available depends on the type of ICMB device you are trying to manage.

Through the ISC Console software, you can switch your view of the primary managed server to
one of the ICMB-managed devices and view the available information on that device without
losing the connection with the primary server.  You can change your view back to the primary
server or any other ICMB-managed device at any time.  Through the ISC Console software, you
can configure the ICMB management features of the primary managed server and the remote
ICMB managed devices.

• Local ICMB Server Configuration— With this option it is possible to enable the local server
as a management point, enable the full sensor view of remote devices, and change the
discovery period for remote devices.

• Remote ICMB Chassis Configuration— With this option it is possible to configure each
remote device discovered via ICMB.  You can decide whether to manage the remote device,
enable full sensor view for the remote device, and set the event polling rate for the remote
device.

You can reclaim inactive ICMB system resources on the primary server.  Doing so frees the
memory taken up by the SDR and FRU information on the primary server for any remote device
that is no longer visible on the network (via ICMB).

Third-Party Instrumentation
You can configure event actions for DMI indications generated by third-party Server
Instrumentation installed with ISC.  You can also monitor third-party instrumentation via the DMI
Explorer Interface.  ISC supports event configuration for Adaptec SCSI, Symbios SCSI, AMI
RAID, and Intel LAN Adapter Server Instrumentation.
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7 Working in ISC

Viewing / Configuring Sensor Information
To view or configure a sensor (such as voltage, temperature), do the following steps:

1. On the ISC main window, click beside a sensor name in the navigation pane to see the list of
available sensors.

2. Select an entry from the list.
3. Switch between the available tab pages (Sensor Settings, Alert Actions, Sensor Information

or Inventory Information ) to view or update the information.
4. Click <Apply> for any changes made to the sensor configuration.

At any time you can change views to another sensor by selecting another component in the
navigation pane.

If you try to change your view and you have not saved any configuration changes using the Apply
button in the presentation pane, ISC prompts you to save or discard the changes before switching
to a new view.

Viewing System Information
To view system information (such as FRU, Operating System, BIOS, SEL) on the managed server
(or managed ICMB device), do the following steps:

1. On the ISC main window, click beside the System Information name in the ISC navigation
pane to see the list of options.

2. Select an entry from the list.
3. View the information in the corresponding tab page in the presentation pane.

At any time you can change views to another sensor by selecting another component in the
navigation pane.

On components that support FRU data, this inventory information is also displayed on the
Inventory Information tab page associated with that component.

Configuring Thresholds
There are two basic types of threshold:

• Range-based thresholds for which a variety of values can be set.  Example uses: for
temperatures, voltages, and RPM-sensing fans.

• State-based thresholds that have fixed values like OK or Critical.  Example uses: for rotation-
sensing fan, chassis door, and memory array.
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To Configure a Range-Based Threshold

Most voltage and temperature sensors and RPM-sensing fans have either one, two, or four
configurable thresholds, depending on the motherboard in your server.  Example thresholds are:

• Upper Critical
• Upper Noncritical
• Lower Noncritical
• Lower Critical

Some special sensors do not have configurable thresholds and are displayed for monitoring
purposes only.

You can customize the threshold value to suit your working environment.

You can specify what action should occur when the sensor detects that one of the threshold values
has been crossed (i.e., the sensor state changes).  Example state change conditions:

• Status Changed to OK
• Status Changed to Upper Critical
• Status Changed from OK to Upper Noncritical
• Status Changed from Critical to Upper Noncritical

These thresholds and sensor state changes let you configure progressive responses in ISC to
increasingly serious hardware conditions.  For example, noncritical thresholds might be configured
to emit a beep from the speaker and send a broadcast message, while critical thresholds might
require more serious actions, like a server shutdown.

To configure a range-based threshold:

1. On the ISC main window, click beside the sensor name in the navigation pane to see the list of
available sensors.

2. Select an entry from the list.
3. Change the threshold values as needed on the Sensor Settings tab page.
4. Click <Apply> for any changes made to the threshold value configurations.
5. If you want to change the event actions associated with threshold state change conditions,

make the changes on the Alert Actions tab page.
6. Click <Apply> for any changes made to the alert action configuration.

✏ NOTE
After applying new threshold values that may cause an event indication, the
sensor status icon displayed on the Sensor Settings tab page may not change.
The console refreshes the display before the new threshold value takes effect
on the server, making it appear as though the sensor icon does not accurately
reflect the current state of the sensor.  Use the menu option, View->Refresh,
or the F5 keyboard shortcut, to update the Sensor Settings tab page.
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To Configure a State-Based Threshold

The state-based thresholds for processor, power supply, rotation-sensing fans, chassis door, and
memory arrays have a fixed set of values, not a range.  Example state change conditions:

• Single Bit Memory Error
• Processor Thermal Trip
• Power Supply Failed

✏ NOTE
For systems that support rotation-sensing fans, the fan RPM threshold
setting displays a “0” and is read-only in the ISC Console software.

ISC generates an event whenever the state of these items changes.  You can specify which actions
should occur in response to changes.  To configure a state-based threshold:

1. On the ISC main window, click beside a sensor name in the navigation pane to see a list of
available sensors.

2. Select an entry from the list.
3. Select the Alert Actions tab.  Change the event actions associated with a state change

condition.
4. Click <Apply> to save your changes.

Cautions in Setting Thresholds

Threshold Values Rounded Off

When you are setting thresholds, the values you enter might not be the exact values set by the
software.  This behavior is caused by hardware rounding.  Redisplay the Sensor Settings tab page
to find the actual value set by the software.

Avoiding a Power On/Off Loop

Improperly setting event actions can cause the server to enter a state that prevents the server from
booting correctly.  This can occur in the following scenario:

1. An event occurs.  Example: a high-temperature threshold is exceeded.
2. While the condition causing the event still exists, you set a Shutdown/Power Control Action,

like Immediate Power Off, to respond to this event.
3. Because the threshold has already been exceeded, no event is triggered to cause the Immediate

Power Off action to occur.
4. If you reboot the system and the event condition has not been corrected (such as the

temperature is still over threshold), the system detects the temperature condition, triggers the
event, and the corresponding action is taken.  In this example action, Immediate Power Off, the
system is automatically and immediately powered off.
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When the system is powered up, an infinite loop of power-up and power-down begins.  To break
this cycle, you have two options:

1. Clear the event condition (cool down the system in this example).
2. Create a file named C:\LRA.NOT (or insert a diskette with file \LRA.NOT in A: drive) before

the OS boots.  The existence of this file will disable the software component that responds to
the event.  The contents of the file are not important.  This file can be created by booting DOS.
You must then delete this file after the problem is fixed to allow the software to operate
normally.  On UnixWare systems, either create a LRA.NOT file in / (root) directory or use the
diskette described above.

Avoiding a Reboot-Fail Retry Loop

User-defined threshold values and other user-defined configuration attributes are written to disk
(persistent storage) so they are available when the server reboots.  These “remembered” values
replace the ISC default values when ISC initializes.

When you change a threshold value or alert action in ISC, you can create an environment in which
an event is immediately generated, such as setting the Upper Noncritical Threshold value below the
current sensor reading.  If the configured event actions on this threshold included a Shutdown or
Power Control action as described earlier, the server would trigger the Shutdown or Power Control
action and could enter a reboot-fail-reboot-fail cycle using the new threshold value.

To help avoid this situation, ISC updates the server in two steps:

1. Any change you make is valid immediately in the active instrumentation, but ISC waits five
minutes before writing user changes to disk.  Thus, if the change causes the server to reboot,
the previous value is restored from disk when the server reboots.

2. ISC then uses and displays the previous value, thus avoiding the immediate reboot-fail-reboot-
fail cycle.

Any change you make will be successfully written to disk as long as the motherboard
instrumentation continues running for five minutes after the change is saved.

Configuring Threshold Event Actions

On the Alert Actions tab page, you can select actions that will take place when a sensor exceeds a
threshold or changes state.  Several options exist.

• Local actions:
 Audio/visual notifications (you may select more than one)
 Shutdown/power control actions (you may only select one)

• Network actions:
 AMS2

 actions (if LANDesk Server Manager is installed on the server and console).
Generally, audio/visual notifications and AMS2

 alerts are for noncritical thresholds;
shutdown/power control actions are for critical thresholds.
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AMS2-configurable alert actions include:

• Paging
• Program execution
• SNMP trap generation
• Message box, broadcast, and others

For more information on AMS2 and its alert actions, see “Configuring AMS2
 Alert Actions” in the

Intel LANDesk Server Manager Administrator’s Guide.

CAUTION
If the OS is disabled by a non-critical event action (such as configuring an
OS shutdown action for a voltage surge), then critical actions will not be
carried out because the OS has been shut down.  It is best to use warnings
(such as a speaker beep, a broadcast, etc.) for non-critical conditions.

The following tables list the available actions in ISC.  You can specify multiple audio/visual
notifications and AMS2 alerts per event but only one shutdown/power control action.

Table 9. Audio/Visual Notifications

Action Description

Emit a beep from the
managed server’s
speaker

Speaker emits a beep.

Display an alert message
on the managed server

Default action for noncritical and critical indications.  The message box stays
up until acknowledged.

On UnixWare, the alert message is displayed as a text message on the
server console.

Log the event to disk Default action for all indications.  This option records the event in the
standard system error log.

On NetWare, ISC records the event in the System Log, which you can view
with NetWare’s Syscon utility.

On Windows NT, ISC records the event in the Application Event Log, which
you can view with the Windows NT Event Viewer.

On UnixWare, events are logged in the system log file: /etc/.osm.

Broadcast a message Default action for critical indications.

On NetWare, the message goes to all users currently logged into the
managed server with Administrator or Supervisor privileges.

On Windows NT, the message goes to all the users currently logged into the
managed server.

Note:  Win95/98 cannot receive network broadcast messages from
Windows NT.  If you configure a broadcast message and it is triggered on an
NT server, the message will not be received by any Win95/98 systems.

On UnixWare, a text message is sent to all users currently logged onto the
UNIX server.

Write a message to the
managed server’s LCD

Default action for all indications.  If the LCD is not available on the managed
server, this option is grayed out and disabled.
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Table 10. Shutdown/Power Control Actions

Action Description

No shutdown Default action for all indications.  Select this option if you do not want to shut
down or reset the server when an event occurs.

Shutdown the OS Select this option if you want to shut down the OS gracefully (controlled, closing
files and applications).

On NetWare, the server is returned to DOS.

On Windows NT, the server is set to a state ready for manual power-off or reset.

On UnixWare, standard shutdown is completed and system prompts for reboot
or power off.

Shutdown the OS and
power off

Select this option if you want to shutdown the OS gracefully and turn off the
system power.

Shutdown the OS and
hardware reset

Select this option if you want to shutdown the OS gracefully and reset the server
via hardware.

Immediate power off Select this option if you want to immediately power down the server.  This action
is an immediate power-off without a shutdown of the OS; it might corrupt files.

Immediate hardware
reset

Select this option if you want to immediately reset the server via hardware.  This
action is an immediate hard reset without a shutdown of the OS; it might corrupt
files.

Immediate NMI Select this option if you want to cause a hardware Non-Maskable Interrupt
(NMI).  If this feature is not supported on the managed server, this option is
grayed out and disabled.

Procedure:

1. On the ISC main window, click beside a sensor name in the navigation pane to see the list of
available sensors.

2. Select an entry from the list.
3. Select the Alert Actions tab.
4. Select the threshold type or state change condition.
5. Change the event actions associated with the selected threshold type or state change condition.
6. Click <Apply> to save your changes.

Configuring Third-Party Event Actions
On the Alert Actions tab page, you can select actions that will take place when a third-party
component exceeds a threshold or changes state.

You can configure event actions for the following third-party components:

• Adaptec SCSI
• Symbios SCSI
• AMI RAID
• Intel LAN Adapter
• Mylex RAID (supported on servers running previous versions of LDSM)
• APC UPS (supported on servers running previous versions of LDSM)
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To configure event actions for third-party indications:

1. On the ISC main window, click beside the third-party component name in the navigation pane.
2. Update the Alert Actions tab.  Change the event actions associated with a threshold type or

state change condition.
3. Click <Apply> to save your changes.

The following table provides event information for third-party component instrumentation
supported by ISC.

Table 11. Configurable Third-Party Events

Instrument (Notes) Choices

Adaptec SCSI* Storage Device Events
Storage device member marked down
Storage device recovered error - Bad block repaired
Storage device state information
Storage Controller Events
Storage Controller state information
Storage Controller SMART event
Storage Controller status unacceptable
Volume Set Events
Volume set state information
Volume set recovered error
Volume set Array status - offline
Spare Events
ARO spare not functional
Enclosure Events
Enclosure state information

Symbios SCSI* Storage Device Events Group:
Self-Monitoring Warning (predictive failure—data recovery possible)
Self-Monitoring Warning (predictive failure—data recovery questionable)
Storage Controller Events Group:
Storage Controller Error (not responding)

AMI RAID* Physical Drive Alerts Group:
Physical drive state change, noncritical (drive online)
Physical drive state change, critical (drive failure)
Physical drive rebuild started
Hot spare created

Intel LAN Adapter Indication Control Group:
Total transmit errors threshold
Total receive errors threshold
Total host errors threshold
Total wire errors threshold

Continued
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Table 11. Configurable Third-Party Events (continued)

Instrument (Notes) Choices

Mylex RAID* Controller Information Group:
Rebuild in progress
Rebuild completed
Rebuild failed
New drive failed
Source drive failed
Rebuild failed
Bad blocks on source drive
Errors when flushing cached data to disks
Hot spare replacement table is full
Device change list is full
Physical Drive Information Group:
Dead
Dead (no autoreplacement within 30 sec)
Rebuilding hot spare drive

APC UPS Battery Status:
Unknown
Battery normal
Battery low

* Event actions do not distinguish between instances of the same group.  This means that event actions are configured for
a “class” of objects (i.e., host adapter) and not on individual instances of the group (i.e., host adapter 1, host adapter 2).

Switching Views Between the Primary (Managing)
Server and an ICMB Device

To view a different server (ICMB device) in the navigation pane of the ISC main window, do the
following steps:

1. On the ISC Main Menu Bar, click the ICMB->View Managed Server(s) menu selection.
2. A list of ICMB devices is displayed.  Select an entry from the list to view.
3. Click <OK>.

The tree in the navigation pane is replaced with information about the new device.  At any time
you can change views to another ICMB device by repeating the steps above.

To return your view to the primary server in the navigation pane of the ISC main window, click the
ICMB->View Managing Server menu selection on the ISC Main Menu Bar.

Configuring ICMB on the Primary (Managing) Server
To configure ICMB on the primary (managing) server, do the following steps:

1. On the ISC Main Menu Bar, click the ICMB->View Managing Server menu selection to
switch to the primary server if you are viewing an ICMB device.

2. In the ISC navigation pane, click beside the ICMB component name in the navigation pane.
3. Update the ICMB tab page.
4. Click <Apply> for any changes made to the ICMB configuration.
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Powering Off the Managed Server or ICMB Device
To immediately power down the currently managed server or ICMB device, do the following steps:

1. On the ISC Main Menu Bar, click the Configure->Immediate Power Off Server menu
selection.

2. Update the confirmation dialog.
3. Click <OK>.

CAUTION
This option is an immediate power-off without a shutdown of the OS, and it
might corrupt files.  Performing this action on the primary (managing server)
will terminate your ISC session.  Performing this action on a ICMB-
managed device will change the power state of the device, but ISC will
continue to run.  You can then power-on the ICMB-managed device, or
change your view to another server.

Powering-on the Managed ICMB Device
To power-on the currently managed ICMB device that is in a powered-down state, do the following
steps:

1. On the ISC Main Menu Bar, click the Configure->Immediate Power On Server menu selection.
2. Update the confirmation dialog.
3. Click <OK>.

Resetting the Managed Server or ICMB Device
To do an immediate hardware reset of the currently managed server or ICMB device, do the
following steps:

1. On the ISC Main Menu Bar, click the Configure->Immediate Hardware Reset Server menu
selection.

2. Update the confirmation dialog.
3. Click <OK>.

CAUTION
This option is an immediate hardware reset without a shutdown of the OS,
and it might corrupt files.  Performing this action on the primary (managing
server) will terminate your ISC session.  Performing this action on a ICMB-
managed device will reset the device, but ISC will continue to run.  You can
continue managing that device, or change your view to another server.
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Configuring the Watchdog Timer Value
To configure the watchdog timer value, do the following steps:

1. On the ISC Main Menu Bar, click the Configure->Watchdog Timer Value menu selection.
2. Update the timer value.
3. Click <OK>.

Customizing ISC Administrator Options
ISC has several adjustable options.  You can set the ISC console refresh rate, determining how ISC
is updated with current information.  You can specify whether temperatures display in Celsius or
Fahrenheit, and whether you want to restore ISC settings to the factory defaults.

ISC installs with the following defaults:

• ISC console refresh interval: 15 seconds
• Temperature display format: Celsius
• Watchdog feature: off
• Watchdog timer: two minutes
• Sensor threshold values as defined in the SDR file

To configure the refresh interval or temperature display format:

1. On the ISC Main Menu Bar, click the View->Options menu selection.
2. Change the refresh interval or temperature display format on the Options dialog.
3. Click <OK>.

To restore default ISC settings for threshold values, console refresh interval, and the watchdog
feature:

1. On the ISC Main Menu Bar, click the Configure->Restore Factory Defaults menu selection.
2. Click <OK> on the confirmation dialog.

✏✏ NOTE
Event actions you have configured and the temperature display format are
not affected by the Restore Factory Default option.

CAUTIONS
Indications may be generated if the restore of the default threshold value
crosses the current sensor value.  For example:

User defined threshold limit 13.5 V

Current sensor value 13.0 V

Default threshold value 12.5 V
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When you select the Restore Default Settings action, threshold restore may
cause a threshold crossing.  In the above example, ISC would detect a
threshold crossing and generate an indication.  The actions associated with
that indication would occur.  To avoid the possibility of unwanted
indications when restoring default settings, Intel recommends, for each
sensor where you do not want indications, that before you select the Restore
Default Settings action, you adjust the user-defined threshold value so the
current sensor value is NOT between the user-defined threshold value and
the default threshold value.
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8 Managing via DMI

The DMI Service Provider runs on each managed Windows NT, NetWare, or UnixWare server and
stores the various MIF files in a database.  The service provider manages component information
by collecting it from the MIF database and component instrumentation code.  The service provider
then passes the information to the DMI browser or other management applications upon request.
Any changes made by the management application or DMI browser are set via the service provider.
The service provider either writes changes to the MIF database or changes attribute values via
component instrumentation code.

Each DMI component must provide a MIF file.  Some of the attributes listed in the MIF files are
read-only, so you can view only their current values.  Other attributes are read-write.  For example,
the Adaptec SCSI controller instrumentation’s Poll Devices attribute is read-write.  Changing the
value of this attribute through a DMI browser changes the setting in the instrumentation software.
Whether attributes are read-only or read-write depends on whether the component has
instrumentation code to enable DMI to change its value.

ISC installs component instrumentation and MIF files for the following:

• Baseboard
• ICMB
• Local Response Agent
• Adaptec SCSI
• Symbios SCSI
• AMI RAID
• Mylex RAID
• Intel LAN Adapter
• APC UPS

To manage the third-party component instrumentation and MIF files, use the DMI Explorer
browser.

CAUTION
Use ISC, not the DMI Explorer browser, to view or set attributes for the
Baseboard and Local Response Agent MIF components.  ISC hides some
complicated interactions of attribute data.  Modifying this data inadvertently
by using the DMI browser interface might cause unpredictable results and
make system recovery difficult.
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Using the DMI Explorer Browser to Manage
Components

Installation

The DMI Explorer Browser is installed automatically when ISC is installed into systems with an
Enterprise Management Console (such as HP’s Network Node Manager or CA—Unicenter TNG)
or the ISC Stand-alone environment.  The Browser is not installed with LANDesk Server Manager.

Starting the DMI Explorer

The DMI Explorer Browser appears as an applet in the Enterprise Management Console or as a
supported tool under the ISC Stand-alone environment.

Viewing Attributes

You can use DMI Explorer to view attribute values for each DMI-compliant component.  To view
the attributes:

• In the left pane, select the component and group you are interested in.  The attributes and
values appear in the right pane.

To navigate through a table of attribute values:

• To move to the next row in the table, click the Next Row button on the toolbar.
• To move to the first row in the table, click the First Row button.
• To search the table for a specific row, click the Search Row button.

✏✏ NOTE
You may see the number 2147483648 when viewing attribute information
with DMI Explorer.  This number is equivalent to 80000000 hex, which
indicates that the item is unsupported.

Refreshing Attributes

Attribute values change from time to time.  Whenever you select a group or display a new row in a
table, DMI Explorer displays a “snapshot” of the data that is accurate at that time.

You may want to refresh the information manually if you suspect that it might have changed.  To
refresh the data:

• Click View->Refresh.
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Viewing Properties

You can use DMI Explorer to view properties for the computer, components, groups, or attributes.
To display properties:

1. Select the item you’re interested in.
2. Click Properties.

Setting The View Options

DMI Explorer offers several different view options.

To turn the toolbar on or off:

• Click View->Toolbar.

To turn the status bar on or off:

• Click View->Status Bar

To change the view of the right pane:

• Click View->Large Icons, Small Icons, List, or Details.

To sort the items in the right pane in a different order:

• Click View->Arrange Icons and select the text that corresponds to the column you want to sort
by.

Or:

• Click the button above the column.

✏✏ NOTE
All of the options above are available by right-clicking while the cursor is
over white space in the right pane.

To specify whether each view is displayed in a single window or separate windows:

1. Click View->Options.
2. Click the Browsing Format tab.
3. Choose the display format.
4. Click OK.

To change the view of integer values to hex or decimal format:

1. Click View->Options.
2. Click the Attribute Format tab.
3. Choose a display format.
4. Click OK.
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Modifying Attribute Values

Attribute values for DMI components either reside in the MIF database or are calculated by
instrumentation.  Instrumentation consists of executable or overlay files used to obtain and/or
change attribute values.  You can modify values for read-write or write-only attributes.

To modify an attribute value:

1. Double-click the attribute name.
2. Place the cursor in the edit box and enter the new value.
3. Click OK.

Adding and Removing Components

You can use DMI Explorer to manage third-party DMI-compliant components.  To do this, you
must install the third-party MIF file.  When you install an MIF file, a component is added to the
DMI-Compliant Components list.  Components can only be installed locally.

To add a component:

1. Select the computer icon in the tree pane.
2. Click File->Add->Component.

When you no longer want to manage a component using DMI Explorer, uninstall it.  This removes
the component MIF file from the MIF database and the DMI Explorer.

To remove a component:

• Select the component and click File->Remove.

Changing the DMI Language

Use the DMI Language Selection option to change the default DMI language encoding to Unicode
or ISO8859-1.  If the framework fails to identify the DMI language encoding of a component, it
automatically uses the default DMI language coding.

To change the DMI language selection:

1. Click View->Language.
2. Choose the language from the list of languages.
3. Click OK.
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9 Third-Party Component Instrumentation

This section describes the available MIF information for third-party component instrumentation.

Adaptec SCSI
The table on the following page lists the Adaptec SCSI instrumentation available in ISC.  You can
view and configure the Adaptec SCSI attributes through the DMI browser interface.

Adaptec SCSI instrumentation supports event generation.

The Windows NT CIOArrayManagement service periodically writes to the following log file:
%WIN32DMIPATH%\BIN\IOMGR.LOG.  The service updates this log file during a discovery or
polling scan for SCSI devices.

You can change the frequency of these scans by updating the DiscoveryInterval and PollInterval
options in the %WIN32DMIPATH %\BIN\IOMGR.INI file.  To specify new time intervals
(specified in seconds) for these scans, change the following options:

DiscoveryInterval=1800

PollInterval=180

Shorter time intervals cause the instrumentation to react quicker to changes in SCSI devices, but
shorter intervals increase the system overhead and make the log file grow faster.  You can delete
the IOMGR.LOG file at any time without affecting the CIO Array Management service.  Adaptec’s
monitoring of drive ‘health’ is dependent on the OS’s SCSI bus device discovery and auto-
assignment of SCSI IDs for discovered logical units at system hardware boot time.  Any logical
units assigned SCSI IDs at system boot time will be detected by Adaptec’s instrumentation
initialization ‘SCAN’ and registered for the polling cycle check performed every PollInterval
seconds.  A device without a SCSI ID is not detected by the SCAN function and is not registered
for the Adaptec health check.  Every DiscoveryInterval, a ‘SCAN’ is initiated to verify the health
of all devices that are known to the operating system.  Any failed device will be dropped from the
list of devices to POLL.  Every PollInterval, a ‘POLL’ is initiated to verify the health of known
‘good’ devices.  Typical SCSI devices (logical units) monitored are drives and back-planes.

If a device fails, the SCAN or POLL cycle will detect that it has failed and generate a failed event.
A failed device can be replaced by a new device (or reinserted) in the same physical slot.  A SCAN
will find this new device and generate a device-recovered event.

You can initiate a new SCAN or POLL by setting the Scan Devices or Poll Devices attribute in the
Operation Group in the Adaptec MIF.

New devices inserted in previously unoccupied or undetected slots (no SCSI ID assigned) will only
be detected by the OS during system hardware boot.  Once these ‘new’ devices have a SCSI ID,
they will be monitored by the Adaptec instrumentation.
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Table 12. Adaptec SCSI Informat ion Available in ISC

Item State Item State

Component ID Storage Devices Events
Enclosure Events
Storage Controller Events
Bus Port Events
Volume Set Events
Volume Set Activity Events
Redundancy Group Events
Spare Events
Association Events

Manufacturer RO Event Type RO

Product RO Event Severity RO

Version RO Event is State-Based RO

Serial Number RO Event State Key RO

Installation RO Associated Group RO

Verify RO Event System RO

Storage Devices Event Subsystem RO

Storage Device Index RO Event Solution RO

Type RO Instance Data Present RO

Type Description RO Event Message RO

Sub-Identifier RO Vendor Specific Data RO

Media Data Block Size RO Event Object RO

Formatted Media Capacity RO CI/O Physical Object State RO

Removable Device RO Enclosure

Device Loaded RO Enclosure Index RO

Removable Media RO Type RO

Media Loaded RO Description RO

Compression RO Bus Port

Encryption RO Bus Port Index RO

Storage Controller Protocol RO

Controller Index RO Protocol Description RO

Identification RO Signal Characteristics RO

Protection Management RO Address Descriptor RO

Bus Master RO Isochronous RO

Second Since Last Power-Up Maximum Width RO

Aggregate Physical Extent Maximum Transfer Rate RO

Aggregate Physical Extent Index RO Maximum Number of
Attachments

RO

Number of Blocks RO Connector Type RO

Continued
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Table 12. Adaptec SCSI Instrumentation Available in ISC (continued)

Item State Item State

Number of Blocks of Check data RO Connector Type Description RO

Aggregate Protected Space
Extent

Connector Gender RO

Aggregate Protected Space
Extent Index

RO Redundancy Group

Number of Blocks RO Redundancy Group Index RO

Volume Set Redundancy Type RO

Volume Set Index RO Mast Storage Association

Name RO Association Index RO

Total Storage Capacity RO Type RO

Protected Space Stripe Length RO Reference 1 RO

Protected Space Extent
Interleave depth

RO Reference 2 RO

Bus Port Association Worldwide Identifier

Bus Port Association Index RO Worldwide Identifier Index RO

Negotiated Speed RO Worldwide Identifier Type RO

Negotiated Width RO Worldwide Identifier RO

Component Spare Association Operational State

Component Spare Index RO Operational State Index RO

Spare Functioning State RO Device Group Index RO

Mass Storage Statistics Operational Status RO

Statistics Index RO Usage State RO

Blocks Read RO Availability Status RO

Blocks Written RO Administrative State RO

Read Commands Issued RO Fatal Error Count RO

Write Commands Issued RO Major Error Count RO

I/O Range 0-12 Read RO Warning Error Count RO

I/O Range 0-12 Written
RO Current Error Status RO

Overall Status RO Device Predicted Failure Status RO

Event Log Count Event State

Event Log Count RO Event State Index RO

Event Log Event Generation Group Class RO

Event Log Index RO Event Type RO

Continued



60

Table 12. Adaptec SCSI Instrumentation Available in ISC (continued)

Item State Item State

Event Log Entry RO Print State RO

Event Log Timestamp RO Associated Group Object RO

MIFTOMIB

MIB OID RO

Disable Trap RW

Symbios SCSI
Table 13 lists the Symbios SCSI instrumentation available in ISC.  You can view and configure the
Symbios SCSI attributes through the DMI browser interface.  Symbios SCSI instrumentation
supports event generation.

Table 13. Symbios SCSI Instrumentation Available in ISC

Item State Item State

Component ID Storage Controller

Manufacturer RO Controller Index RO

Product RO Identification RO

Version RO Worldwide Identifier Type RO

Serial Number RO Worldwide Identifier RO

Installation RO Protection Management RO

Verify RO Bus Master RO

Software Component Information Seconds Since Last Power-up RO

Major Version RO FRU Group Index RO

Minor Version RO Operational Group Index RO

Revision RO Bus Port

Build RO Bus Port Index RO

Target Operating System RO Protocol RO

Language Edition RO Protocol Description RO

Identification Code RO Signal Characteristics RO

Installable State RO Worldwide Identifier Type RO

Executable State RO Worldwide Identifier RO

Software Signature Address Descriptor RO

File Name RO Isochronous RO

File Size RO Maximum Width RO

File Date and Time RO Maximum Transfer Rate RO

File Checksum RO Maximum Number of
Attachments

RO

Continued
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Table 13. Symbios SCSI Instrumentation Available in ISC (continued)

Item State Item State

File CRC 1 RO Connector Type RO

File CRC 2 RO Connector Type Description RO

File Location RO Connector Gender RO

Field Replaceable Unit Operational Group Index RO

FRU Index RO Mass Storage Statistics Group
Index

RO

Device Group Index RO Mass Storage Association

Description RO Association Index RO

Manufacturer RO Mass Storage Association Type RO

Model RO Object 1 Type RO

Part Number RO Object 1 Index RO

FRU Serial Number RO Object 2 Type

Revision Level RO Object 2 Index

Warranty Start Date RO Bus Port Association

Warranty Duration RO Bus Port Association Index RO

Support Phone Number RO Negotiated Speed RO

Storage Devices Negotiated Width RO

Storage Device Index RO Operational State

Type RO Operational State Instance
Index

RO

Type Description RO Device Group Index RO

Worldwide Identifier Type RO Operational Status RO

Worldwide Identifier RO Usage State RO

Sub Identifier RO Availability Status RO

Media Data Block Size RO Administrative State RO

Formatted Media Capacity RO Fatal Error Count RO

Removable Device RO Major Error Count RO

Device Loaded RO Warning Error Count RO

Removable Media RO Current Error Status RO

Media Loaded RO Device Predicted Failure Status RO

Compression RO Sym SDMS Mass Storage
System

Encryption RO Sym Device Index RO

FRU Group Index RO Sym Device Key RW

Operational Group Index RO SMART Reporting Capability RW

Continued
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Table 13. Symbios SCSI Instrumentation Available in ISC (continued)

Item State Item State

Storage Devices Events /

Storage Controller Events /

Bus Port Events /

Mass Storage Association Events

SMART Polling Period RW

Storage Devices Event Type /

Storage Controller Event Type /

Bus Port Event Type /

Mass Storage Association Event Type

RO MIFTOMIB

Event Severity RO MIB Name RO

Is Event State Based RO MIB OID RO

Event State Key RO Disable Traps RW

Associated Group RO

Event System RO

Event Subsystem RO

AMI RAID
The following table lists the AMI RAID instrumentation available in ISC.  You can view and
configure the AMI RAID attributes through the DMI browser interface.  AMI RAID
instrumentation supports event generation.

Table 14. AMI RAID Instrumentation Available in ISC

Item State Item State

Component ID Physical Device Information

Manufacturer RO Physical Adapter Number RO

Product RO Physical Channel RO

Version RO Target ID RO

Serial Number RO State RW

Installation RO Array Position RO

Verify RO Size (in MB) RO

Controller Information Device Type RO

ADP Adapter Number RO Inquiry String RO

Firmware Version RO SCSI Level RO

BIOS Version RO Sync. Negotiation RO

Num. Logical Drives RO QTags RO

Dram Size (in MB) RO Rebuild Progress RW

Chipset Type RO Medium Errors RO

Rebuild Rate ( % ) RO Other Errors RO

Flush Interval RO All Attributes RO

Continued
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Table 14. AMI RAID Instrumentation Available in ISC (continued)

Item State Item State

Maximum Concurrent Commands RO Channels

Spin Up Delay RO Channel Adapter Number RO

Spin Up Count RO Channel RO

ADP IO Reads (sec) RO Terminations RO

ADP IO Writes (sec) RO Channel Status RO

ADP Reads (KBS/sec) RO Alert Management Information

ADP Writes (KBS/sec) RO DMI Indication RW

ADP Read Failures (sec) RO AMS2 Alerts RW

ADP Write Failures (sec) RO Event Log RW

Scan Channels RW Global Info

Logical View RO Global Controller Information RO

Physical View RO Composite Drive Alerts

Physical Drive Alerts

Logical Drive Information Event Type RO

LD Adapter Number RO Event Severity RO

Logical Drive Number RO Is Event State Based RO

RAID Level RO Event State Key RO

Status RW Associated Group RO

Size (in MB) RO Event System RO

Stripe Size RO Event Subsystem RO

Read Policy RW Event Solution RO

Write Policy RW Instance Data Present RO

Cache Policy RW Vendor Specific Message RO

Number Of Spans RO Vendor Specific Data RO

Number Of Stripes RO Vendor Trap Number RO

LD IO Reads (sec) RO MIFTOMIB

LD IO Writes (sec) RO AMI MegaRAID MIB RO

LD Reads (KBS/sec) RO MIB OID RO

LD Write (KBS/sec) RO Disable Traps RO

LD IO Read Failures (sec) RO

LD IO Write Failures (sec) RO

Progress RW

All Attributes RO
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Intel LAN Adapter
Table 15 lists the Intel LAN 82559 Fast Ethernet† PCI Bus Controller instrumentation available in
ISC.  You can view and configure the Intel LAN Adapter attributes through the DMI browser
interface.

On NetWare servers, the Intel LAN Adapter instrumentation supports event generation.  The MIF
information available from the LAN Adapter instrumentation on Windows NT is a subset of the
information available from the instrumentation on NetWare.  The following table identifies the
supported groups and attributes for NetWare and Windows NT.

Table 15. LAN 82559 Instrumentat ion Available in ISC

Attribute NetWare Windows NT

Component ID

Manufacturer RO RO

Product RO RO

Version RO Unsupported*

Serial Number RO Unsupported*

Installation RO RO

Verify RO RO

Intel Network Adapter Instrumentation
Group

MIF ID RO RO

Version RO RO

Intel Network Adapter Driver Extensions
Group

Index RO RO

Driver File Path RO RO

Driver File Date RO RO

Intel Ether-like Group

Index RO RO

Alignment Errors RO RO

FCS Errors RO RO

Single Collision Frames RO RO

Multiple Collision Frames RO RO

SQE Test Errors RO RO

Deferred Transmissions RO RO

Late Collisions RO RO

Excessive Collisions RO RO

Internal Mac Transmit Errors RO RO

Carrier Sense Errors RO RO

Frame Too Longs RO RO

Continued
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Table 15. LAN 82559 Instrumentat ion Available in ISC (continued)

Attribute NetWare Windows NT

Internal Mac Receive Errors RO RO

EtherChipSet RO RO

Network Adapter 802 Port Group

Port Index RO RO

Permanent Network Address RO RO

Current Network Address RO RO

Connector Type RO RO

Data Rate RO RO

Total Packets Transmitted RO RO

Total Bytes Transmitted RO RO

Total Packets Received RO RO

Total Bytes Received RO RO

Total Transmit Errors RO RO

Total Receive Errors RO RO

Total Host Errors RO RO

Total Wire Errors RO RO

Network Adapter Driver Group

Driver Index RO RO

Driver Software Name RO RO

Driver Software Version RO RO

Driver Software Description RO RO

Driver Size RO RO

Driver Interface Type RO RO

Driver Interface Version RO RO

Driver Interface Description RO RO

MIFTOMIB

MIB Name RO RO

MIB OID RO RO

Disable Trap RW RW

* “Unsupported” attributes are specified in the standard LAN MIF groups but are not supported in the Intel LAN MIF.
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Mylex RAID
The following table lists the Mylex RAID instrumentation available in ISC.  The Mylex RAID
instrumentation is supported only on servers running 2.8 versions of LDSM.  You can view and
configure the Mylex RAID attributes through the DMI browser interface.

Mylex RAID instrumentation supports event generation.

Table 16. Mylex RAID Instrumentation Available in ISC

Item State Item State

Component ID Physical Device Information

Manufacturer RO Controller Number RO

Product RO SCSI Bus ID RO

Version RO SCSI Target ID RO

Serial Number RO Operational State RO

Installation RO Vendor ID RO

Verify RO Product ID RO

Controller Information Product Revision Level RO

Controller Number RO Size (in MB) RO

Operational State RO Device Type RO

Firmware Revision RO Soft Errors Count RO

Configured Channels RO Hard Errors Count RO

Actual Channels RO Parity Errors Count RO

Maximum Logical Drives RO Misc Errors Count RO

Maximum Targets Per Channel RO Logical Drive Statistics

Maximum Tagged Requests RO Controller Number RO

Max. Data Transfer Size Per I/O Req. RO Logical Drive Number RO

Maximum Concurrent Commands RO Read Requests Count RO

Rebuild Rate RO Amount of Data Read (in MB) RO

Logical Sector Size (in Bytes) RO Write Requests Count RO

Physical Sector Size (in Bytes) RO Amount of Data Written (in MB) RO

Cache Line Size (in Bytes) RO Read Cache Hit ( % ) RO

DRAM Size (in MB) RO Physical Drive Statistics

EPROM Size (in KB) RO Controller Number RO

Bus Type RO SCSI Bus ID RO

System Bus Number RO SCSI Target ID RO

Slot Number RO Read Requests Count RO

Interrupt Vector Number RO Amount of Data Read (in KB) RO

Interrupt Mode RO Write Requests Count RO

Continued
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Table 16. Mylex RAID Instrumentation Available in ISC (continued)

Item State Item State

Logical Drive Information Amount of Data Written (in KB) RO

Controller Number RO Error Control Group

Logical Drive Number RO SelfID RO

Operational State RO Fatal Errors Count RO

RAID Level RO Major Errors Count RO

Write Policy RO Warning Errors Count RO

Size (in MB) RO Error Status RO

Stripe Size (in Bytes) RO Error Status Type RO

Physical Drive Map RO Alarm Generation RW

Mylex DAC960 Component
Inst. Info.

MIFTOMIB

CI Revision RO MDAC MIB RO

CI Build Date RO MIB OID RO

MDAC Device Driver Revision RO Disable Trap RW

MDAC Device Driver Build Date RO

APC UPS
The following table lists the APC UPS instrumentation available in ISC.  The APC UPS
instrumentation is supported only on servers running 2.8 versions of LDSM.  You can view and
configure the APC UPS attributes through the DMI browser interface.

APC UPS instrumentation supports event generation.

Table 17. APC UPS Instrumentation Available in ISC

Item State Item State

Component ID Operational State

Manufacturer RO Operational State Instance Index RO

Product RO Device Group Index RO

Version RO Operational Status RO

Serial Number RO Usage State RO

Installation RO Availability Status RO

Verify RO Administrative State RO

UPS Battery Fatal Error Count RO

Battery Status RO Major Error Count RO

Seconds On Battery RO Warning Error Count RO

Estimated Minutes Remaining RO Current Error Status RO

Estimated Charge Remaining RO Operational State Table RO

Battery Voltage RO Diagnostic Function Group

Continued
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Table 17. APC UPS Instrumentation Available in ISC (continued)

Item State Item State

Battery Current RO Diagnostic Function Table Index RO

Temperature Probe Index RO Diagnostic Function Name RO

FRU Group Index RO Diagnostic Function Description RO

Operational Group Index RO Exclusive Access Required RO

Temperature Probe Prerequisite Conditions RO

Temperature Probe Table Index RO Prerequisite Diagnostic Function RO

Temperature Probe Location RO Diagnostic Request Group

Temperature Probe Description RO Diagnostic Function Reserve Key RW

Temperature Status RO Diagnostic Function Request RW

Temperature Probe Temp. Reading RO Diagnostic Function Result RO

Monitored Temp. Nominal Reading RO Diagnostic Results Group

Monitored Temp. Normal Maximum RO Diagnostic Function ID RO

Temperature Probe Maximum RO Diagnostic Function Result RO

Temperature Probe Minimum RO Diagnostic Function Result Desc. RO

Temp. Reading Lower Threshold
Noncritical

RW Fault Isolated to this Component RO

Temperature Reading Upper
Threshold Noncritical

RW Error Control

Temperature Reading Lower
Threshold Critical

RW Self ID RO

Temperature Reading Upper
Threshold Critical

RW Number of Fatal Errors RO

Temperature Reading Lower
Threshold Nonrecoverable

RW Number of Major Errors RO

Temperature Reading Upper
Threshold Nonrecoverable

RW Number of Warnings RO

Temperature Probe Resolution RW Error Status RO

Temperature Probe Tolerance RW Error Status Type RO

Temperature Probe Accuracy RW Alarm Generation RW

FRU Group Index RO MIFTOMIB

Operational Group Index RO MIB Name RO

MIB OID RO

Disable Trap RW
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10 DMI to SNMP Translator

You can use the DMI-SNMP Translator to integrate DMI management with SNMP.  The translator
attaches directly to the Network OS’s SNMP agent and to the DMI Service Layer by registering as
a management application.  The translator translates management requests from SNMP to DMI and
responses from DMI to SNMP.  DMI events (indications generated by the component
instrumentation when a threshold is crossed or a sensor changes state) are translated into enterprise-
specific SNMP traps.

The translator translates these MIFs:

• Baseboard
• ICMB
• Local Response Agent
• Adaptec SCSI
• Symbios SCSI
• AMI RAID
• Intel LAN Adapter

The translator raises a trap when a DMI indication is received.  The DMI-SNMP Translator does
not support configured actions.  This alerting mechanism works independently of the Local
Response Agent.

For the DMI-SNMP Translator to work correctly, the SNMP Agent on the managed server OS
must be configured correctly.  For example, the Windows NT, NetWare, or UnixWare SNMP
Agents need some configuration to enable the server to send SNMP traps to specific SNMP
management consoles.  To configure the SNMP Agent on the server, see the documentation
supplied by the OS vendor.

To manage the DMI information supplied by ISC software through the SNMP management
workstation, the following MIBs must be compiled on the SNMP console:

• ADAPTEC.MIB
• BASEBRD.MIB
• BASEBRD2.MIB
• BASEBRD3.MIB
• ICMBFEAT.MIB
• RMTCHAS.MIB
• E100B.MIB
• LRA.MIB
• MEGARAID.MIB
• SYMSDMS.MIB
• INTELNIC.MIB
• CIO.MIB
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These MIB files are installed during the ISC Console and ISC Server installation.  The files are
copied to the %ISC_PATH%\SNMPMIBS directory during installation.  ISC_PATH is the
installation directory chosen during install.

The procedures for compiling these MIBs depend on the SNMP console being used.  For more
information, see the documentation supplied with your SNMP console software.
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11 ISC Event Messages

ISC allows you to configure event actions to be taken on the managed server when an event occurs.
These actions include audio/visual notifications, such as:

• Display an alert message
• Write a message to the LCD
• Broadcast a message

The message text is based on the event information.  This text contains the DMI MIF group and
attribute information that caused the error.

Alert Messages on the Server Console
The following table lists the alert messages that display on the server console.  The general format
of these messages is:

Event reported for <attribute_name>  attribute in the <group_name>  group.

Table 18. Server Console Alert Messages

Alert Message Description

Event reported for Upper Critical Threshold
attribute in the Temperature Sensor group.

A temperature sensor on the system reported that the
current value is above the upper critical range.

Event reported for Upper Noncritical Threshold
attribute in the Temperature Sensor group.

A temperature sensor on the system reported that the
current value is above the upper noncritical range but
below the upper critical range.  This message is also
generated when the temperature returns to the
acceptable range.

Event reported for Lower Noncritical Threshold
attribute in the Temperature Sensor group.

A temperature sensor on the system reported that the
current value is below the lower noncritical range but
above the lower critical range.  This message is also
generated when the temperature returns to the
acceptable range.

Event reported for Lower Critical Threshold
attribute in the Temperature Sensor group.

A temperature sensor on the system reported that the
current value is below the lower critical range.

Event reported for Upper Critical Threshold
attribute in the Voltage Sensor group.

A voltage sensor on the system reported that the
current value is above the upper critical range.

Event reported for Upper Noncritical Threshold
attribute in the Voltage Sensor group.

A voltage sensor on the system reported that the
current value is above the upper noncritical range but
below the upper critical range.  This message is also
generated when the voltage returns to the acceptable
range.

Continued
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Table 18. Server Console Alert Messages (continued)

Alert Message Description

Event reported for Lower Noncritical Threshold
attribute in the Voltage Sensor group.

A voltage sensor on the system reported that the
current value is below the lower noncritical range but
above the lower critical range.  This message is also
generated when the voltage returns to the acceptable
range.

Event reported for Lower Critical Threshold
attribute in the Voltage Sensor group.

A voltage sensor on the system reported that the
current value is below the lower critical range.

Event reported for Current Status attribute in
the Security Sensor group.

System chassis front panel or side panel has been
opened (or it was open and has been closed).

Event reported for Current Status attribute in
the Cooling Fan group.

System fan has stopped (or restarted).

Event reported for Array Error Type attribute in
the Memory Array group.

A memory error has been reported on the system.

Event reported for Event Status attribute in the
Logical Unit group.

A SCSI device reported a state change.

Event reported for Event Status attribute in the
Host Adapter group.

A SCSI board reported a state change.

Event reported for Operational State attribute in
the Controller Information group.

A RAID controller reported a state change.

Event reported for Operational State attribute in
the Physical Drive Information group.

A RAID drive reported a state change.

Event reported for Processor Status attribute in
the Processor group.

A processor sensor on the system reported a
processor error.

Event reported for Power Unit Redundancy
Status attribute in the Power Unit Global Table
group.

The power supply redundancy sensor on the system
reported a power supply redundancy state change.

Event reported for Total Transmit Errors
Threshold attribute in the Indication Control
group.

The LAN Adapter reported that the number of transmit
errors is above the threshold value.

Event reported for Total Receive Errors
Threshold attribute in the Indication Control
group.

The LAN Adapter reported that the number of receive
errors is above the threshold value.

Event reported for Total Host Errors Threshold
attribute in the Indication Control group.

The LAN Adapter reported that the number of host
errors is above the threshold value.

Event reported for Total Wire Errors Threshold
attribute in the Indication Control group.

The LAN Adapter reported that the number of wire
errors is above the threshold value.

Event “Status Changed to OK” reported in the
Voltage Probe group.

A Voltage probe changed its status to an OK state.

Event “Status Changed to Lower Critical”
reported in the Voltage Probe group.

A Voltage probe changed its status to Lower Critical
state.

Event “Status Changed to Upper Critical”
reported in the Voltage Probe group.

A Voltage probe changed its status to Upper Critical
state.

Event “Status Changed from OK to Lower
Noncritical” reported in the Voltage Probe
group.

A Voltage probe changed its status from normal to
Lower Noncritical state.

Continued
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Table 18. Server Console Alert Messages (continued)

Event “Status Changed from OK to Upper
Noncritical” reported in the Voltage Probe
group.

A Voltage probe changed its status from normal to
Upper Noncritical state.

Event “Status Changed from Lower Critical to
Lower Noncritical” reported in the Voltage
Probe group.

A Voltage probe changed its status from Lower Critical
to Lower Noncritical state.

Event “Status Changed from Upper Critical to
Upper Noncritical” reported in the Voltage
Probe group.

A Voltage probe changed its status from Upper Critical
to Upper Noncritical state.

Event “Status Changed to OK” reported in the
Temperature Probe group.

A Temperature probe changed its status to an OK
state.

Event “Status Changed to Lower Critical”
reported in the Temperature Probe group.

A Temperature probe changed its status to Lower
Critical state.

Event “Status Changed to Upper Critical”
reported in the Temperature Probe group.

A Temperature probe changed its status to Upper
Critical state.

Event “Status Changed from OK to Lower
Noncritical” reported in the Temperature Probe
group.

A Temperature probe changed its status from normal to
Lower Noncritical state.

Event “Status Changed from OK to Upper
Noncritical” reported in the Temperature Probe
group.

A Temperature probe changed its status from normal to
Upper Noncritical state.

Event “Status Changed from Lower Critical to
Lower Noncritical” reported in the Temperature
Probe group.

A Temperature probe changed its status from Lower
Critical to Lower Noncritical state.

Event “Status Changed from Upper Critical to
Upper Noncritical” reported in the Temperature
Probe group.

A Temperature probe changed its status from Upper
Critical to Upper Noncritical state.

Event “Internal Error” reported in the Processor
group.

A system processor reported an internal error.

Event “Thermal Trip Error” reported in the
Processor group.

A system processor reported a Thermal Trip error.

Event “FRB Error” reported in the Processor
group.

A system processor reported an error during the FRB
(Fault Resilient Boot) sequence.

Event “Redundancy Lost” reported in the Power
Unit Global Table group.

A power unit on the system lost the redundancy state.

Event “Redundancy Regained” reported in the
Power Unit Global Table group.

A power unit on the system regained the redundancy
state.

Event  reported on the Storage Device Event
Type attribute in the Storage Device Events
group.

A predictive failure noncritical on a SCSI device.

Event  reported on the Storage Controller Event
Type attribute in the Storage Controller Events
group.

A SCSI controller reported a state change.

Event reported for Event Type attribute in the
Physical Drive Alerts group.

A RAID device reported a state change.
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Broadcast and LCD messages
The following table lists broadcast and LCD messages.

Broadcast messages are sent across the network to client computers.  The general format of
broadcast messages is:

Check < group_name> at server < server_name>

LCD messages are displayed on the managed server’s LCD.  These are limited to 32 characters;
longer messages are truncated.  The general format of LCD messages is:

Check: < group_name>

Table 19. Broadcast and LCD Messages

Message Description

Check: Temperature Sensor.
Check: Temperature Probe.

A temperature sensor reported a change in state
(OK/Noncritical/Critical).

Check: Voltage Sensor.
Check: Voltage Probe.

A voltage sensor reported a change in state
(OK/Noncritical/Critical).

Check: Security Sensor.
Check: Physical Container Global Table.

System chassis front panel or side panel has been opened (or
it was open and has been closed).

Check: Cooling Fan. System fan has stopped (or restarted).

Check: Memory Array. A memory error has been reported on the system.

Check: Host Adapter. A SCSI board reported a state change.

Check: Logical Unit. A SCSI device reported a state change.

Check: Controller Information. A RAID controller reported a state change.

Check: Physical Drive Information. A RAID drive reported a state change.

Check: Processor. A processor error has been reported on the system.

Check: Power Unit Global Table. A power unit redundancy state change has been reported on
the system.

Check: Power Supply. A power supply failed on the system.

Check: Indication Control Group. The LAN Adapter reported a threshold crossing.

Check: Storage Device Events. A SCSI device reported a state change.

Check: Storage Controller Events. A SCSI controller reported a state change.

Check: Physical Drive Alerts. A RAID drive reported a state change.
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12 ISC Sensor Thresholds

The following table lists default values for voltage and temperature sensor thresholds for the
AP450GX MP motherboard.  ISC maintains these values.

For the remaining supported motherboards, default threshold values are stored in Sensor Data
Records (SDR) in nonvolatile storage on the motherboard.  These values are determined and
configured during motherboard manufacturing and are therefore not documented in this manual.

Table 20. AP450GX MP Motherboard Thres holds

Lower Critical Lower Noncritical Upper Noncritical Upper Critical

Voltage Sensor
(value in V)

12V 09.96 10.44 13.56 14.04

5V 04.4 04.6 05.4 05.6

3V 02.9 03.04 03.56 03.7

Temperature Sensors
(value in °C)

CPU 10.36 0.56 44.52 54.32

I/O Slot Area 10.36 0.56 44.52 54.32
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A Using the Intel Server Control Console

Introduction
The Intel Server Control Console is a lightweight management console that provides basic server
management functions.  It allows you to run ISC, DMI Explorer browser, or other server
management tools without using an Enterprise Management Console (such as LANDesk Server
Manager).  It also allows you to run the Emergency Management Port console application on
servers that have EMP capability.

The ISC Console provides you with the ability to:

• Discover Intel servers

• Discover management tools on those servers

• Launch the management tools on the managed servers

The ISC Console runs in one of three ways:

• As an executable program

• Under Microsoft Management Console

• As an ActiveX Control under Netscape Navigator or Internet Explorer

Scope
This appendix describes the user interface and controls of the ISC Console.

See Chapter 3 for information about installing the ISC Console.

See Chapter 4 for information about launching the ISC Console.
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Intel Server Control Console Main Screen
Figure 2 shows the Intel Server Control Console, running with Internet Explorer.

Figure 2. ISC Console Main S creen

A Button bar
B Tool Pane (page 82)
C Status Bar (page 82)
D Navigation Pane (page 82)

ISC Console Button Bar
The ISC Console uses a Windows Explorer-like model, with a navigation pane (tree view) and a
presentation pane (list view). Servers that are discovered are added to the tree view.  When you
select a server from the tree, the presentation pane shows a list of supported “tools” running on that

A

B

C

D
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server.  You launch the supported tool from the presentation pane by double-clicking on the tool
icon.

The Button Bar includes the following options:

Table 21. Button Bar Items

Item Options

Server Menu Discover: Start server discovery

Stop Discovery: Cancel currently running discovery process

Add: Manually add a server to the tree

Delete: Delete the selected server from the tree

Delete All: Delete all servers from the tree

View Menu Large Icons: View the tool list with large icons

Small Icons: View the tool list with small icons

Options: Configure server/tool views

Tools Menu Launch Selected Tool: Start the selected tool for the selected server

Launch EMP: Start the Emergency Management Port Console Manager

Help Menu Help Topics:  Accesses ISC Console help topics
About ISC Console:  Displays ISC Console version information

Server Menu Options

Discover
You can discover multiple servers in a single step and add them to the server tree.  Servers are
discovered using a Ping Sweep mechanism supported on servers running TCP/IP.

To discover a range of servers with IP addresses, do the following steps:

1. On the Button Bar, click the Server->Discover menu selection.
2. Enter the starting address and ending address to be discovered.  The starting address will

default to the network subnet of the console machine starting at address 0.  The ending range
will default to the value 255, indicating that ISC will search the entire network subnet.  If you
change the default address value, enter the full IP address.  Wild card characters are not
allowed.  For all IP addresses, the range of  values allowed for any IP address segment is
between 0 and 255.

3. Click <OK>.

The ISC Console will ping each server and test each server for all ISC-registered tools.  If one or
more of the tools is found, then the server will be added to the server tree.  The server will appear
under the appropriate OS-specific branch of the server tree, depending on which OS is running on
the server.  If the OS on the server cannot be determined, the server will be added under the Servers
of Unknown Type branch.

During the discovery process, the status bar indicates ping status, those servers found, and those
servers not responding.
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Information on servers discovered through ISC is maintained across machine boots.  When the ISC
Console is run, servers discovered during previous sessions are displayed.  You do not have to run
discovery every time the ISC Console is launched.

If any of the tools supported by the ISC Console are installed or removed from any managed
server, the ISC Console discovery process will need to be rerun on that server to update the tool list
for that server.

Stop Discover
This selection ends the discovery process.

Add
You can manually add a server with an IP or IPX address to the ISC Console server tree.

To add a server with an IP or IPX address, do the following steps:

1. On the Button Bar, click the Server->Add menu selection.
2. Choose a radio button for either the IP label or the IPX/SPX label.  The default is “IP address.”
3. Enter the full address of the desired server.  Wild card characters are not allowed.  For all IP

addresses, the range of  values allowed for any IP address segment is between 0 and 255.  For
an IPX/SPX address, you must specify all 20  (8 and 12) characters that make up the Net and
Node portions of an IPX/SPX address.

4. Click <OK>.

The ISC Console will test the specified server for all ISC-registered tools.  If one or more of the
tools is found, then the server will be added to the server tree.  The server will appear under the
appropriate OS-specific branch of the server tree, depending on which OS is running on the server.
If the OS on the server cannot be determined, the server will be added under the Servers of
Unknown Type branch.

Delete/Delete All
You can manually delete a server from the ISC Console server tree.

To delete a server, do the following steps:

1. Select a server or multiple servers from either the Windows NT Servers, NetWare Servers,
UnixWare Servers, or Servers of Unknown Type branch in the server tree.

2. On the Button Bar, click the Server->Delete or Server->Delete All menu selection.
3. A confirmation dialog will be displayed.  Click <OK>.

ISC will delete the server(s) from the server tree.  To restore information about that server, you
must rediscover the server using Server->Add or Server->Discover.

View Menu Options

Large Icons/Small Icons
Changes the size of the icons in the Tool Pane.
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Options
The server tree view may be configured to display tool information in many configurations.  You
can show all the servers discovered, regardless of what tools are supported.  You can display the
set of servers that only support a single tool, or the set of servers supporting a combination of tools.

To view all tools on all discovered servers, do the following steps:

1. On the Button Bar, click the View->Options menu selection.
2. Click the radio button next to View All Tools.
3. Click <OK>.

To configure the server view for specific tools, do the following steps:

1. On the Button Bar, click the View->Options menu selection.
2. Click the radio button next to View Selected Tools Only.
3. Check the boxes in the tool list for the tools to be selected for display.
4. Click <OK>.

If View All Tools is selected, the ISC Console will display all discovered servers where one or
more of the supported tools is found.

If View Selected Tools Only is selected, the ISC Console will only display those discovered
servers that have the specified supported tools.

Tools Menu Options

Launch Selected Tool
Once you have discovered a server and the tools supported on that server, you can start the tool
from the ISC Console.

To start a tool by using the menu options, do the following steps:

1. Select a server from either the Windows NT Servers, NetWare Servers, UnixWare Servers, or
Servers of Unknown Type branch in the server tree.

2. Select the desired tool from the list view on the main dialog for the specified server.
3. On the Button Bar, click the Tools->Launch Selected Tool menu selection.

To start a tool from the Tool Pane, do the following steps:

1. Select a server from either the Windows NT Servers, NetWare Servers, UnixWare Servers or
Servers of Unknown Type branch in the server tree.

2. Double-click on the desired tool in the Tool Pane.

Launch EMP
The Emergency Management Port (EMP) Console Manager is a supported tool in the ISC Console,
but is not discovered on the server.  EMP is a out-of-band management application that requires
modem support on the console and the managed server, or a direct connection between the console
and the managed server.
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The following server control operations are available with the EMP Console Manager:
• Connecting to remote servers
• Powering the server on or off
• Resetting the server
• Switching the server console between EMP active and BIOS re-direct modes

The ISC Console provides a launch point for the EMP application through the menu options, but
EMP will not appear as a supported tool under a selected server.

To start the Emergency Management Port Console Manager:

1. On the Button Bar, click the ToolsLaunch->EMP menu selection.

See the Release Notes for a list of baseboards that provide EMP support.

See the Product Guide for the managed server for information about using the EMP Console
Manager.

Help Menu Options

Help Topics
Displays the online help dialog for the ISC Console.

About ISC Console Help
Displays the version number of the ISC Console.

Navigation Pane
The Navigation pane shows a tree view of servers with management tools that have been
discovered.  Servers are organized based on the operating system running on the server.  ISC has
tree branches for Windows NT Servers, NetWare Servers, UnixWare Servers, and a branch for
servers where ISC could not determine the operating system type called Servers of Unknown Type.
These branches have expansion icons (“+” or “-”) appearing to the left of them. These branches can
be expanded to list managed servers or collapsed to hide managed servers.

Tool Pane
When you select a server in the navigation pane, the tool pane displays a set of icons representing
the management tools supported on that server.  You can start the management tool for the
managed server by double-clicking on the tool icon in the tool pane.

Status Bar
The status bar displays information about ISC Console operations, such as the number of servers
found with valid addresses and number of servers not responding during a Discover.
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